Modded Mustang Forums banner
1 - 12 of 12 Posts

·
Billy Weston
Joined
·
5,076 Posts
Discussion Starter · #1 ·
I am starting to iron out all of the problems with my Pioneer Avic. The next problem on the list is poor FM reception.
I have shortened the stock antenna down to the roof line. Although I shortened the antenna long before I replaced the head unit and never had an issue. I have removed the head unit to check the antenna connection to the deck and it all looks fine. Any ideas?
 

·
Premium Member
Joined
·
10,464 Posts
have you checked the connection all the way up to the mast itself? IIRC isnt there a point by the glove box where there is a connection as well?
 

·
Billy Weston
Joined
·
5,076 Posts
Discussion Starter · #3 ·
sure but none of it has been touched. I'll take a look for shits and giggles but I have a good feeling they're good.

I have been thinking its something wrong with the head unit or it just doesn't like the shortened mast.
 

·
Premium Member
Joined
·
10,464 Posts
do you have anything else in the car like an external satellite tuner?
 

·
Billy Weston
Joined
·
5,076 Posts
Discussion Starter · #5 ·
No right now it's just the head unit wired into the mach 460 with a ipod plugged into the aux jack in the front.
 

·
Registered
Joined
·
6,139 Posts
every car i've owned with an aftermarket HU has had issues getting FM reception, compared to the stock head unit.
 

·
Premium Member
Joined
·
10,464 Posts
hmmmm.... thats wierd as Pioneers have that Supertuner that amplifies the signal of am and fm stations. You can try taking a piece of wire and connecting it to the antenna while you insert it into the hole and then take the other end and put it to a ground source to see if the signals pick up. If for some reason your ground is inadequate on the power harness it will pull ground from the antenna causing the signal to diminish
 

·
Premium Member
Joined
·
10,464 Posts
every car i've owned with an aftermarket HU has had issues getting FM reception, compared to the stock head unit.
really... ive never had an issue with mine or anyone's that ive installed

Have any of you ever used a FM signal amp?
I have used them at one time or another they do work.
 

·
Billy Weston
Joined
·
5,076 Posts
Discussion Starter · #10 ·
Most stations are OK but I listen to 96x all the time and it sounds like poop.
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
really... ive never had an issue with mine or anyone's that ive installed
+1, I don't even have an antenna on my car. I shaved it, and I still get good reception with my Pioneer unit...
 
1 - 12 of 12 Posts
Top