Modded Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
292 Posts
Discussion Starter #1
So my car was running just fine till I decided to mess with it and then murphy's law kicked me in the nuts, I got a k&n that bolts right up to the maf sensor and that is the only change I did I didnt switch mafs or anything and now my car wont idle it just surges and then dies, but then sometimes it will run fine and idle normal, then I heard that u need like 9 inches before ur maf so it just not random air flowing in and throw everything off, I have no freaking clue what the crap to do and I dont have my old intake anymore so do u think putting a velocity stack inside the K&N would help regulate air flow because I went from a really tiny air filter to a pretty stinking big one and I wish I had my camera to take a picture but dont know where it is. Anyone know what I should do?
 

·
Banned
Joined
·
2,194 Posts
for every action there is an equal and opposite reaction?

or is that the douche bag that was like
if everything can go wrong it will
 

·
Registered
Joined
·
4,781 Posts
The air filter is your problem, your getting poor signal at idle due to turbulance. get a 90 degree bend pipe and an air filter from autozone and the filter in your fenderwell.
 

·
Registered
Joined
·
3,659 Posts
Maybe you sucked some filter oil into your sample area and the MAS wire is dirty?
I have a K&N bolted directly to a Pro-M, both are in the fender well at the end of a power pipe. I DO have some random idle surging on occasion though ;)
 

·
Registered
Joined
·
4,781 Posts
pro-m is a much better meter though
More specifically ProM meters are designed for the filter to be bolted on them and have 360 degree sampling. Stock and C&L meters are very dependent on having non-turbulent air.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #8
ok that is what i have heard is that i need a straight pattern of air leading in to my maf so it is not so random?
 

·
Registered
Joined
·
146 Posts
did you unplug the mass air when you changed the filter there is a rubber o ring in the meter that comes out this will stop the plug from going all the way in i had that problem then car ran like **** would stall all that stuff you also sound like your geting fan wash the elbo would help but you have to clock the mass air because the way the air bend threw the tubue so you get a good reading in the meter, also can also block of the side of the filter by the fan with a peice of sheet metal
 

·
Registered
Joined
·
193 Posts
open filter may cause some idle surge, but not what you're describing. check the mass air plug and make sure no k&n oil got on the mass air. and it wouldn't hurt to put some shield around the filter to keep the fan/underhood heat from affecting the filter
 

·
Registered
Joined
·
2,950 Posts
i have a K&N filter stuck right on the end of the MAF.....all other intake is stock.....basically i just have the cone filter that replaces the box....no surgeing
 
1 - 11 of 11 Posts
Top