Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,405 Posts
Discussion Starter #1
Was slow at work today so I was searching around on the ford message boards, and seems like there's been a few tech's who've had the '11's come in with burned up #8 pistons already. I haven't heard of anything on these forums however so it made me wonder. Also it looked like all the cars the techs were dealing with were stock, or returned to stock anyways.
 

·
Registered
Joined
·
195 Posts
I've checked my plugs every oil change, well all 3 of them anyway. Not one of them looks any different from the rest.
 

·
Registered
Joined
·
3,405 Posts
Discussion Starter #4
i just found it surprising after seeing so many threads about blowers installed and making 600+ with stock longblocks. hopefully it's just an early build thing or something.
 

·
Registered
Joined
·
2,592 Posts
One car had an issue with number 8 pistoj and everyone started to freak out. I wouldn't worry about it. Out of all the 5.0s out there you can probably countthe ones that had piston#8 problems with your hands.
 

·
Registered
Joined
·
119 Posts
One car had an issue with number 8 pistoj and everyone started to freak out. I wouldn't worry about it. Out of all the 5.0s out there you can probably countthe ones that had piston#8 problems with your hands.
That and at least the picture I saw wasn't a burnt out piston. It look like a portion of the piston actually got snapped off.
 

·
Registered
Joined
·
577 Posts
There is a good tech thread on S197 about it from Livernois. Some good information minus the name calling. Seems like it has only been a handful of cars but no pics of plugs or a gas analysis. I am really curious if it wasn't bad gas on a 93 race tune.
 

·
Don't BAAAAH 'Til Goatsday
Joined
·
6,530 Posts
Seems likes he was the first person on the interwebs to have a problem like that. Ouch.
 
1 - 8 of 8 Posts
Top