Modded Mustang Forums banner
1 - 20 of 24 Posts

·
Drag Queen
Joined
·
985 Posts
Discussion Starter · #1 ·
Hey guys, I have never seen anything like this nor can I make sense of it.

When I am in nuetral not moving (5 spd) with the parking brake on and I rev the engine to about 3000rpm and give it a tap to 4000rpm my speedometer jumps!?

after a 10 minute drive and stop sometimes it doesn't happen.

The car is running great as usual nothing different,no issues, no check engine lights etc.. the speedometer functions normally while driving as well.

Has anyone ever seen this? could it be a sign of trouble?

here are the video clips...



 

·
Registered
Joined
·
476 Posts
clueless...first time ive seen that
 

·
Registered
Joined
·
509 Posts
its happen to me a few time lol i didnt think anything of it
 

·
Registered
Joined
·
2,043 Posts
My '05 doesn't do that ****.
 

·
Registered
Joined
·
2,465 Posts
Hehe, that used to happen to Lulu when he was around here. I dunno what's up with it. But I have seen other people with that problem.
 

·
Registered
Joined
·
1,923 Posts
happened to my friend but that was only because he tried to burn out in reverse and broke 3 teeth off of his reverse gear haha
 

·
Registered
Joined
·
1,676 Posts
There was a owner who's car used to do that but he had all sorts of electrical bugs...
 

·
Drag Queen
Joined
·
985 Posts
Discussion Starter · #11 ·
Everything else seems fine maybe i will have the dealer take a look some people saying it's normal? i really haven't noticed it till now... so i dont think it's normal because it would have been happening for ever?
 

·
Premium Member
Joined
·
22,435 Posts
Everything else seems fine maybe i will have the dealer take a look some people saying it's normal? i really haven't noticed it till now... so i dont think it's normal because it would have been happening for ever?
I'll check my car tomorrow. I don't see how it'd be normal unless all of our cars do it.
 

·
Registered
Joined
·
1,427 Posts
That is the "Hey Dumbass your parking brake is on warning"

Normal....
I perfer to call it "The Idiot Light!":p

So i got bored and went and tried it and my speedo jumps when revving it but no parking brake thing:eek:
 

·
Drag Queen
Joined
·
985 Posts
Discussion Starter · #15 ·
I perfer to call it "The Idiot Light!":p

So i got bored and went and tried it and my speedo jumps when revving it but no parking brake thing:eek:


well thats 5 people so far that it happens to lol.. i will bring it up at the net oil change :)

btw your parking brake warning is broken lol any time the speedo moves it should yell at you thinking the car is moving.
 

·
At the Apex pulling 1.28g
Joined
·
6,578 Posts
well thats 5 people so far that it happens to lol.. i will bring it up at the net oil change :)

btw your parking brake warning is broken lol any time the speedo moves it should yell at you thinking the car is moving.
Happens to me too but only if I get close or go over the redline. 100% bone stock 2009 Mustang GT. I've got 7500 miles on my car. Not sure why it does it, personally it seemed normal to me?
 

·
Registered
Joined
·
739 Posts
Hey, guys sorry to bring back on old tread, but I just noticed mine doing this same thing today minus the parking brake warning. Now after a couple years have you guys found out what this issue is or if its an issue at all.
 

·
Hardon Enthusiast
Joined
·
2,291 Posts
yeah i saw mine do the same thing the other day without the parking brake.
 
1 - 20 of 24 Posts
Top