Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3,089 Posts
Discussion Starter #1
Ever since I bought my 03 gt my battery light goes on and off. The previous owner installed some uderdrive pullies and i have no clue as to what brand they are. Ive checked my battery and Im positive my alternator is fine bc im not having any charging issues and the car never has a hard time starting up. The light goes on and off but is on most of the time. Could these unkown udp's be causing my battery light to come on? If not what else could it be? I want to switch to the steeda udp's anyways but id still like to know whats causing the light to come on and off.
 

·
mm's nitrous mod
Joined
·
12,988 Posts
take pics and post them. might be able to figure out what UDP's they are. i was having the same issues with my stock pulley's in high rpm's, and my UDP's cured that.
 

·
Registered
Joined
·
56 Posts
If they reduced your alternator output enough the battery could be affected by the lower charging amperage.
 

·
N/A 4v Guru
Joined
·
3,484 Posts
take pics and post them. might be able to figure out what UDP's they are. i was having the same issues with my stock pulley's in high rpm's, and my UDP's cured that.

+1 I have the steeda's and I don't have any problem. If they are piggyback style definatly get the steeda's
 

·
Registered
Joined
·
3,089 Posts
Discussion Starter #7
mine are the piggeyback style. So it is possible for my udp's to turn the light on?
 

·
Registered
Joined
·
192 Posts
I dont have ud pulleys but i've had similar problems with the light coming on and off.
 

·
Registered
Joined
·
3,089 Posts
Discussion Starter #9
I dont have ud pulleys but i've had similar problems with the light coming on and off.
Yeah its really ****ing annoying. I may just remove the light bulb for it out of the instrument cluster lol.
 

·
Registered
Joined
·
137 Posts
Ever since I bought my 03 gt my battery light goes on and off. The previous owner installed some uderdrive pullies and i have no clue as to what brand they are. Ive checked my battery and Im positive my alternator is fine bc im not having any charging issues and the car never has a hard time starting up. The light goes on and off but is on most of the time. Could these unkown udp's be causing my battery light to come on? If not what else could it be? I want to switch to the steeda udp's anyways but id still like to know whats causing the light to come on and off.
Clean your battery posts and snug everything down.
Check the wire and connector on the alternator.
Measure across the battery with the car idling and you should see about 14.0 volts, give or take.

Do you have a gigantic audio system or any other power sucking devices in the car?

Chances are it's NOT the pulleys unless you are sitting in bumper to bumper, A/C on, huge audio system etc and even then it's unlikely.

Does it happen when you are driving or just when idling or both?

I agree with the others though, get the Steeda's.

In order:

Poor connections /wiring.
Weak battery.
Weak alternator.
 

·
Registered
Joined
·
3,089 Posts
Discussion Starter #13
Clean your battery posts and snug everything down.
Check the wire and connector on the alternator.
Measure across the battery with the car idling and you should see about 14.0 volts, give or take.

Do you have a gigantic audio system or any other power sucking devices in the car?

Chances are it's NOT the pulleys unless you are sitting in bumper to bumper, A/C on, huge audio system etc and even then it's unlikely.

Does it happen when you are driving or just when idling or both?

I agree with the others though, get the Steeda's.

In order:

Poor connections /wiring.
Weak battery.
Weak alternator.
My audio system is bone stock and it happens when im driving, but when i first start my car in the morning the light is off and when im driving normal the light wont usually come on right away, but if i punch it the light will come on. But most of the time when im just driving normal its on to but will go off and come back on.
 
1 - 14 of 14 Posts
Top