Modded Mustang Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
Over the winter i installed a BBK cold air kit,TFS upper plenum and a 75mm tb.
here's my question what i have noticed is that sometimes when i start car and when i snapped the throttle quickly and let it close it makes this strange humming, reverbitation sound or vibration? and of course idle drops really low and wants to die.
Has anybody else expierenced this? and if so what causes this?
 

·
Nile P. Pezdel of Pez Dispenser Inc. CCA
Joined
·
5,502 Posts
Did you get a tune after all that was installed?
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #3 ·
No, i talked to Don Lasota who did my tunes and he told me that the tunes he provided me with would be fine.
The car runs and drives great and the AFR is fine, i think i will start removing parts of the cold air kit one piece at a time to try to isolate the issue.
 

·
Nile P. Pezdel of Pez Dispenser Inc. CCA
Joined
·
5,502 Posts
Hopefully it's something obvious. I guess since you didn't mention it there's no CEL? If it was the MAF for instance, it'd probably throw a code.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #5 ·
Well here's what have found out, 1st of all some of the idling issue was the throttle body stop screw was out of wack that and a idle re-learn solved some issues.
I figured out a way to duplicate the noise and found it to be a bad IAC motor. and since i removed the silencer from the IAC inlet hose it was reverbitating back into the air intake.
Replace IAC and problem is solved.
 
1 - 5 of 5 Posts
Top