Modded Mustang Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
2,308 Posts
Discussion Starter #1
i put on the gt500 TB yesterday and i threw the P0174 code today. car ran like crap coming home today from car show.
but, my question is, is this code because of the TB, or coincidence and i have another problem?
i was told few weeks ago that changing the TB wouldnt throw a code
 

·
Registered
Joined
·
1,381 Posts
A lean code should have anything to do with your tb. What injectors do your have? Do you have a way to data log and tell if it's going lean at idle or wot?
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #3
i can tell its lean at idle just by driving it. when i let off gas, the air/fuel gauge maxes out. at WOT, it runs great.
i believe the fuel injectors are 39. the car ran absolutely fine until i put in the TB
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #4
now im throwing P0174 and P0171 - too lean bank 1 and 2
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #6
i mean, its just too weird that it ran fine until i put that TB on. after install i only drove it about two miles and it ran ok but never hit above 45.

today on way to car show, when i left off the gas the air/fuel meter maxed out at the limits of my gauge, 20. also, when i left off gas, it just felt like driving straight into a windtunnel, car would slow down quickly. it loved WOT though. i didnt throw codes on way to car show which was 20 miles from house. also, at idle rpms would dip down to 500 then bounce up to 750 up to 1200.

on way home from car show it was running even worse and this is when i threw the codes.

if its not the TB its very odd coincidence.

im going to put the BBK back on in the morning or tongiht once wife and kid go to bed. clear the codes and see what happens. if no codes then i know it was the TB. if still get the codes then i will have to look elsewhere
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #8
wife is staing up longer than expected, so i will throw the BBK back on in the morning and go for a nice test drive. hopefully this clears up answers and i will let you know as soon as i know blackbird.

im also picking up a rental car tomorow and scheduling another dyno tune ASAP this week
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #10
**** no, after this dyno tune i'll have a total of 1500 in dyno tunes in the last year. so beyond pissed right now. this is going to set back any other mods for quite some time. between the dyno tune and rental car im negative $800 in future mods.
my installer/tuner knew of this TB issue and needing to fine tune the car after new TB install. but, he doesnt answer his work phone or the cell phone number that he gave me. this guy is like a ghost.
so, just to get this TB right, i have to spend another $500, at least, to get a dyno tune, just for a ****in minor tweaking of the current tune. the way i justify it though is any future mods, at least i can count on some one to answer the phone and modify my tune when i need it.
sorry for rant and cussing. im just beyond frustrated right now.
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #12
ok, swapped TB back to BBK. drove it about 6 miles. still ran crappy but i figured computer was just trying to readjust. i stop and get a haircut and reload the blower tune, assuming this would reset everything. drove it 6 miles back home and still ran like ****. stopped, reloaded blower tune for a 2nd time. still running like ****.
the computer is acting like its trying to resort it out but im wondering if there is another issue now. but i havnt thrown the codes again after resetting dtc codes.
so, im off to try and find car rental thats open on sunday
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #14
cleaned the MAF and runs just like it did before the TB exchange. so, im guessing because i ran lean with the gt500 TB it dirtied up the MAF.

so, for now we are back to the BBK TB with the hanging issue. hopefully i can get ahold of my tuner tomorow, get a tune adjustment for the GT500 TB and get it put on and just be able to enjoy the car.


but, for future reference to all on here, you DO need a tune adjustment if you change to the GT500 TB
 

·
Registered
Joined
·
1,468 Posts
At least you have it fixed for now.

Why don't you try the GT500 throttle body again, it may have been just a freak occurance that something dirtied up the MAF.
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #16
well, my thought process is, if the MAF gets dirty, its suppose to make you run rich.

my codes were saying i was lean.

another guy on here, 101fng, said he got the same exact codes when he put the same TB on
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #18
no i didnt nasty, not for the GT500. the BBK was tuned with all the other crap. some folks on here couple weeks back ago told me i wouldnt need one. not one person said i would need a tune.
 

·
Registered
Joined
·
1,381 Posts
I personly would have never thought you would need a tune swaping from a 62mm tb to a 60mm tb after already tuning for the 62. Thats crazy. But now i know to get a tune before i put it on.
 

·
Registered
Joined
·
2,308 Posts
Discussion Starter #20
Just got back from imstalling ford racing tb and getting tune worked out. Car runs better than ot has in three months
 
1 - 20 of 22 Posts
Top