Modded Mustang Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just installed a bbk 70mm throttle body and the bbk cai on my 09 mustang. Ran fine for a day now its runnin real rough, and gas mileage went way down. i tried re-programming the bama tuner but its not working, anybody out there have any ideas how to fix the problem?
 

·
Premium Member
Joined
·
2,063 Posts
I just installed a bbk 70mm throttle body and the bbk cai on my 09 mustang. Ran fine for a day now its runnin real rough, and gas mileage went way down. i tried re-programming the bama tuner but its not working, anybody out there have any ideas how to fix the problem?
MilitaryMustang,

This sounds pretty odd, there's a few different things this could be. Start with giving the install a once over and make sure there's no air leaks and everything's tight etc.. We can also look into your tune for you and make sure everything is good to go there. We send out thousands of tunes and build them all from the ground up for your PCM code and your mods. They're not just "canned" tunes, they're built custom by our team, so every once in a while it's possible we mess one up! We'll definitely get it straightened out for you, though! Give one of our Bama Tuning Specialists a call and they'll work with you to figure out exactly what's going on.

Our Bama Performance tuning specialists are here in the building Monday-Friday from 9AM-5:30PM EST and Saturday 9AM-5:30PM EST

-Dan
 
1 - 2 of 2 Posts
Top