Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Help me out before I give up and get rid of the car. I have a supercharged 5.0 that has a loud squeal in one of the pulleys. I think it's the drive pulley, because that's the only one I can't get a listen on by using a metal bar without putting my life in danger. There is no rhyme or reason for when the squealing begins, usually keeps squealing until I stop the car, wait a minute, then drive off again and it becomes quiet only to start again for no apparent eason. I have changed belts, applied silicon (which helps for a short while). I am thinking of changing one pulley at a time and see if I can find the culprit, but I don't really want to go through all that unless I have to. The squealing is embarrasing, and ruins an otherwise nice cruise. Any suggestions would be appreciated. Note: I ruled out the supercharger by removing the belt and running the car without it.
 

·
Registered
Joined
·
5,029 Posts
Help me out before I give up and get rid of the car. I have a supercharged 5.0 that has a loud squeal in one of the pulleys. I think it's the drive pulley, because that's the only one I can't get a listen on by using a metal bar without putting my life in danger. There is no rhyme or reason for when the squealing begins, usually keeps squealing until I stop the car, wait a minute, then drive off again and it becomes quiet only to start again for no apparent eason. I have changed belts, applied silicon (which helps for a short while). I am thinking of changing one pulley at a time and see if I can find the culprit, but I don't really want to go through all that unless I have to. The squealing is embarrasing, and ruins an otherwise nice cruise. Any suggestions would be appreciated. Note: I ruled out the supercharger by removing the belt and running the car without it.
i would haft to think it would be the alt or p/s
 

·
Registered
Joined
·
4,781 Posts
I had the same problem for a long time and replaced every pulley and every accessory and it still squealed. I got the belt prep spray and it would help for awhile, but eventually the squealing would come back. In the end I fixed it. I bought a belt that was 1 full inch smaller and the squealing immediately stopped and never returned. I had to loosen the alternator to get the belt on but there is no belt squeal. Try this or replacing the tensioner. I think the tensioners are like $40 at autozone.
 

·
Registered
Joined
·
5,556 Posts
93 hatch just had this problem it was hit tensioner pully bearing went bad
 
1 - 4 of 4 Posts
Top