Modded Mustang Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1
Hey guys
Took my mustang out today and noticed a very loud squeal over 1500 rpm. Few days before when i first started the car it would squeal at first but go away after the car warmed up however now the car doesn't squeal on cold start up but does under load. I am thinking of replacing the belt when i get some free time. What else should I be looking for if the belt don't fix it.. tensioner maybe? I checked it and it felt very strong. I tried spraying WD-40 on it and it didn't make any difference. It would quiet it down before when it squeaked on cold start up but not nomore. Any help is greatly appreciated.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #3
anyone..?
getting a new belt forsure but just confused if i should get tensioner as well. It seems to be having tension but why would it squeal underload and it gets louder n louder with rpm
 

·
Registered
Joined
·
26 Posts
try putting some wheel bearing grease on the belt that should help quite it down... and a tensioner if that doesnt work
 

·
Registered
Joined
·
813 Posts
spring loaded belt tensioner is worn or one of your bearings inside the pulley is shot. Idler pulley is notorious for being loud... i have a tensioner assembly with pulley hardly used for 20 bucks plus shipping. fits 96-04 GT's 2v, idk if it fits cobra.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #6
i am trying to find a new belt first and see if fixes it. Autovalue didn't have any in gatorback so i gotta find another store. If it still squeals then i'll give you a shout. Iam 50% sure it's tensioner. Fuk had a chick tell me today at the tire shop "you have nice car but there's a weird noise comming from it though" P1SC + belt + tensioner?
 

·
Registered
Joined
·
813 Posts
yeah just dont use too much, if it grabs dirt or dust it will get inside and the bearing will be toast.
 

·
Registered
Joined
·
258 Posts
I usually take a bar of soap and hold it to the belt while the car is running. Just make sure to wear a glove. A fresh belt is never a bad idea.
 

·
Registered
Joined
·
21,024 Posts
It sounds like a pulley. Do like mell0 said.

Cobra emblems on a GT :no
 

·
Full Frontal Nudity
Joined
·
1,725 Posts
Yup it sounds like there is a little bit of a grind along with the squeak, good just be bad quality, either way I would go with a pulley....mind as well change the belt at the same time.....on another note that tach is huge
 

·
Registered
Joined
·
157 Posts
Here's a neat trick. Drip some water on the belt, if the squeak goes away you have an alignment issue and you need to fix it. If the squeak gets worse, you have a tension issue, either the belt needs replacement or the tensioner is shot and you need to fix it.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #15
update: Took everything out changed the belt with gatorback cleaned all the pulleys with the scotch pad and brush. Checked all the pullies they all looked good. tensioner was good too I couldn't move it much by both hands. Squeak has completly gone away for now.
 
1 - 16 of 16 Posts
Top