Modded Mustang Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,359 Posts
Discussion Starter #1
Alright I was going down the road and all of a sudden I see a bunch of white smoke behind me. Said **** and pulled over. I opened the hood to find antifreeze every where and found this on my upper radiator hose


So I called a Friend and we went and got a new hose and two gallons of antifreeze and I replaced it. I knew I had to bleed it So I filled up the radiator until it stopped Bubbling and then started the car. waited Till the Thermostat opened and added some more. Drove back to my place (was only 3 miles) and shut it down when I got back. Waited 10 min. and then took the radaitor cap off and out came air. Filled up again and ran for a solid 15 minutes. and then let cool again and got some more air out. the filled And I repeated this until no more air came out. Drove to work and everything was fine. Held temp

Now here is what worries me. Lately my heater had been working only when IT wants to. Now after work (4 hours) its 15* out (cold car) I had Heat before I left the parking lot. Drove back to my place (10 miles) and let the car idle for another 15 minutes and it holds temp. Should I be worried?
 

·
Registered
Joined
·
1,107 Posts
Now here is what worries me. Lately my heater had been working only when IT wants to. Now after work (4 hours) its 15* out (cold car) I had Heat before I left the parking lot. Drove back to my place (10 miles) and let the car idle for another 15 minutes and it holds temp. Should I be worried?
Sounds like your cooling system is in good working order. But as a preventive measure you should replace all the other hoses because if one blew the other ones are probably old too.
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter #3
Sounds like your cooling system is in good working order. But as a preventive measure you should replace all the other hoses because if one blew the other ones are probably old too.
Tripple checked everything for dryrot and everything looks good
 

·
Registered
Joined
·
1,107 Posts
Tripple checked everything for dryrot and everything looks good
The rubber deteriorates over time from the heat and oil/coolant etc. I haven't seen a lot of hoses dry rot, its usually the opposite they seem to get saturated with oil or coolant and get real soft. Cheap insurance to replace them.
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter #5
Now after work (4 hours) its 15* out (cold car) I had Heat before I left the parking lot. Drove back to my place (10 miles) and let the car idle for another 15 minutes and it holds temp. Should I be worried?
This is what Scares me though.
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter #7
Wouldn't I be losing a little coolant than? sure Hope its Not a Headgaskit.

Should also add that I think that the car has never ran better. I think that I will drive it for now and make sure to keep a eye on the resovor as when I got back From work I was at the cold line. So I added to the hot line. I will go Check In a hour or so to see if it has dropped to the cold line
 

·
R.A.D
Joined
·
5,413 Posts
Mine takes longer then that. Mine take about 5-10 mins while driving for the heater to kick on full heat. around 40 degree weather.
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter #11
Alright I went and took a look at the resovoir level and its was just above the cold. I touched the top coolant hose and it was still warm. I will leave it till morning and go from there I guess
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter #13
Oh I know Im More than Likely good. Just scares the **** out or me. Just get nervous when I fix **** and have to run it. Its the same way with My snowmobiles. I Did Rebuilds on two of them and Im scared to start them For some odd reason :facepalm:
 

·
Poo tee weet?
Joined
·
2,646 Posts
Now here is what worries me. Lately my heater had been working only when IT wants to. Now after work (4 hours) its 15* out (cold car) I had Heat before I left the parking lot. Drove back to my place (10 miles) and let the car idle for another 15 minutes and it holds temp. Should I be worried?
If you're low on coolant you wont get much heat out of it. Maybe you had been low a while. But mine doesnt heat up that fast if it's been sitting for hours.

Where in minne you at?
 

·
Registered
Joined
·
390 Posts
Alright I was going down the road and all of a sudden I see a bunch of white smoke behind me. Said **** and pulled over. I opened the hood to find antifreeze every where and found this on my upper radiator hose


So I called a Friend and we went and got a new hose and two gallons of antifreeze and I replaced it. I knew I had to bleed it So I filled up the radiator until it stopped Bubbling and then started the car. waited Till the Thermostat opened and added some more. Drove back to my place (was only 3 miles) and shut it down when I got back. Waited 10 min. and then took the radaitor cap off and out came air. Filled up again and ran for a solid 15 minutes. and then let cool again and got some more air out. the filled And I repeated this until no more air came out. Drove to work and everything was fine. Held temp

Now here is what worries me. Lately my heater had been working only when IT wants to. Now after work (4 hours) its 15* out (cold car) I had Heat before I left the parking lot. Drove back to my place (10 miles) and let the car idle for another 15 minutes and it holds temp. Should I be worried?
replace the t-stat if you dont know how old it is.
 
1 - 17 of 17 Posts
Top