Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
I tried searching, but I couldn't find what I'm looking for. I was told my a friend from across the country that this is common, but to me, its a first!

I just picked up an 90 gt. Its a previously stolen recovered car. The motors great, everythings good, except some interior panels where they ripped the stereo out and the column where the cracked it.

Regardless, new lights on the car, don't know if they ever worked. Turn them on, after 15 or so minutes, they turn off. Parking lights stay on. High-beam flash to pass works.

So I took the dash apart and found the harness going into the headlight switch is beginning to melt. The wires are good.

Is this as common as my friend says, and if so whats the fix? If not, does anyone have any wiring diagrams? I bought the Chilton book and its useless!

Any help would be appreciated! I plan to bring her back to 100% over the next few months.

Thanks in advance...
 

·
Registered
Joined
·
3,357 Posts
yeah do the fog light fix, file down the melted plastic on that connector check the wiring for breaks, and you will prob need a new turn signal switch. thats what i needed.

try to wiggle the turn signal switch while the lights are on and if they flicker its the turn signal switch, youll need to replace it.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #5
So I did the fog light fix, and so far so good.

I went a little overboard though... I had the relays, so I added two for headlights, high & low beams, 1 for parking lights, and 1 for fogs. As I was going through the wiring, everything looked ok. The harness is a little melted/deformed, but still functions.

Thank you both for your help. I greatly appreciate it!

I'm sure I'll be pretty active here...

Thanks again!
 
1 - 5 of 5 Posts
Top