Modded Mustang Forums banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,416 Posts
Discussion Starter · #1 ·
Well, here is the story.. so I have the car all torn apart, driveshaft out, exhaust off, intake off, (putting new driveshaft, headers, Charge Motion plates, UDP's, and cams(127500's )) So I was pulling the cam sprockets off so I could put my phase lockouts in, and that went well, but for some freakin reason, I took my brain out and tossed it in the garbage, and then took off the driverside sprocket from the cam WITHOUT putting the wedge in.. YEAH, FREAKIN DUMB.. So I have the phase lockouts in, and I know the pass side is fine, but I dont' know if I skipped a tooth on the crank sprocket on the driverside.. everything looks ok, but the only way I will know is to pull the front cover.. So thats my next deal, drain oil and coolant, pull PS pump, and balancer, and take the front cover off.. I have read all the instructions for removing the cover, and checking the timing.. I have to have two chain links on oppsite ends marked up, and one mark has to be inline with a mark on the crank sprocket, and one in line with the L or R (depends on which side of the motor) on the cam phaser.. Im praying that once I get the cover off, I can count links and figure out two that are oppsite from each other, and everything will be ok, and I can just put it back together, other wise I will have to get the right links on the right teeth.. This is real lame, but better safe than sorry.. I can't believe Im such a moron...

So now I am ordering a tool to remove the crankshaft seal, and my driveshaft, cams, and springs should be in today.

Called on my headers this morning, they told me it would be 2 weeks when I ordered them 2 weeks ago, and they said today, that it could be 4 months.. Needless to say they are checking on it..

Just kill me now...

Has anyone done this before? Any imput would be great. Thank you!
 

·
Registered
Joined
·
503 Posts
I didn't jack my timing when I did my cams, but I have done my share of stupid while wrenching. It usually happens with me on the small stuff. Like forgetting to re-install the oil filter before firing the engine after an oil change. Stupid can be a pain in the ass! Best of luck with getting all back together.
 

·
Registered
Joined
·
3,776 Posts
Hey i have faith in you man! you will know that thing in and out! i might just have to take a trip home and you can help install mine when i get there... haha, Good luck!!
 

·
Premium Member
Joined
·
1,416 Posts
Discussion Starter · #4 ·
Id love to help ya with yours, just as long as mines done by then and running.. LOL..

Im such a dipshit....

I didn't sleep last night, just researched the crap out of fixing this.. Proly should take some pics just incase someone else loses there mind.. Doubtful...
 

·
Premium Member
Joined
·
1,416 Posts
Discussion Starter · #6 ·
Yep, they are on there way!!!!! everything should be there today, and the headers should be in later this week.. So hopefully it will be back running this weekend...
 

·
Registered
Joined
·
3,776 Posts
Awesome! I cant wait to watch the video of the aftermath!
 

·
Premium Member
Joined
·
1,416 Posts
Discussion Starter · #8 ·
LMAO.... You should see the garage(single car).. Its like the mustang puked parts everywhere.. actually its all labled nicely in ziploc bags(gf was helping).. Tonight Im going to put the driveshaft, and third link in. tomorrow Ill tear that front cover off and check all that stuff out. Ill tell you one thing, those Charge Motion Delete's from Steeda are awesome, the machine work on them is very very nice, even the time they took to debur everything, with out scratching it all up, is impressive...
 
1 - 8 of 8 Posts
Top