Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter #1
My stang has been sitting for like 3- months cause im getting parts replaced. After putting the new pump in i tried to fire her up but its like the battery wont hold a charge. Im gonna try agin in the morning but ill be jumping the car. Can anyone help me asap plz?:dunno
 

·
Registered
Joined
·
34 Posts
Does the battery need water?
 

·
Registered
Joined
·
197 Posts
Discussion Starter #3
water?? im not sure but its dead for no reason i mean my car just has been sitting, so it should still start rite?
 

·
Registered
Joined
·
4,875 Posts
Even without a draw, 3 months can kill a battery because there's always memory being kept alive in the computer when everything is off. Key off doors shut and you still have a few mA draw on any car with a computer. Put it on a trickle charger at about 2A for a few days and see if it brings it back to life. When you kill a battery completely, sometimes they come back, sometimes they stay weak for good. Just jumping it and running it won't charge it properly. Alternators don't do a very good job of bringing a dead battery back to life.

Whenever you let a car sit for a while, just unhook the negative battery terminal. Battery will stay good for a lot longer that way.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #6
Ok thanks guys. what im gonna do is take my optimum batt from my pops and see if she cranks in the morning. I have used the battery poorly so i dnt doubt its that. Once i crank her up tomorrow hopefully ill keep you guys posted.
 
1 - 6 of 6 Posts
Top