Modded Mustang Forums banner
1 - 20 of 74 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter · #1 ·
Well last night, I decided I wanted to go out and have some "fun". I was at a dead idle, engine fully warmed up and then I started to go in first gear, I pulled the car to about 6K rpms, then quickly shifted from 1st to 2nd gear doing WOT again in 2nd pulling the car up to about 6K rpms again in 2nd gear, I then quickly shifted from 2nd to 3rd gear. The speed limit for the road that I was on was 70mph. I was doing about 68-69 mph, so I wanted to slow down. Not thinking that my car would just shut off on me I put the car in neutral and just started coasting up to the stop sign. I was going approximately 60 mph and my speed was decreasing as my car was in neutral. The rpms were normal ranging from 614-860 rpms. Then, the engine just shuts off... That's the best way I can describe it.

In other words.. Whenever I do WOT on my car and am going 60+ mph and then put the car in neutral it just wants to idle real low and then it shuts off. I have to restart the car to get going again. (it does this every now and then) I'll watch the rpms dip real low and sometimes the engine catches itseld but most of the time when it dips real low it just cuts off.

I've contacted the Ford dealership and they told me that my car has had new spark plugs, ignition coils, fuel pump, fuel filter, oil change, serpentine belt, transmission fluid and transmission serviced, etc. ALL within the past 12,000 miles of the car.

I have a K&N FIPK kit on my car along wit a new pcv, iac, and gatorback belt. Could it be the battery? It's a walmart battery and it was on the car when i bought it. I'm the third owner with 110K miles on it. Thank you.
 

·
It's in the details Mod!
Joined
·
11,051 Posts
Check your IAC. If dirty it will allow your idle to just drop off.
 

·
It's in the details Mod!
Joined
·
11,051 Posts
**** homie. I read right over that and just saw pcv. My bad. I will think of something. My brain is farting right now?
 

·
Registered
Joined
·
2,182 Posts
mine has like tha same problem...each time i race or push my hard hard when i slow down tha rpm drop so low to the point were it wants to turn off unless i give it gas...i replace my iac as well not too long ago
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #7 ·
**** homie. I read right over that and just saw pcv. My bad. I will think of something. My brain is farting right now?
mine has like tha same problem...each time i race or push my hard hard when i slow down tha rpm drop so low to the point were it wants to turn off unless i give it gas...i replace my iac as well not too long ago
That's exactly what happens with mine down to the tee. If I give it gas as I'm catching it dropping low it helps it out. it's funny cuz the lights in the interior start dimming and so do the headlights after I get on it real hard when it wants to start cutting off on me. I was thinking that it might be the battery?
 

·
Admanistrator
Joined
·
13,320 Posts
I heard a similar problem for the S197's : After travelling at highway speeds for a long period, when you come to a stop quickly after slowing down, the car can shut off. But when it is turned back on, it is fine. I believe it had something to do with the fuel pump. It was pumping at one rate, and the computer didn't adjust for the rapid deceleration and stop quick enough, so the car shut off.


Have you changed the A/F ratio at WOT?
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #9 ·
Hmm, thats interesting and I can believe that. No, I have't changed the A/F ration yet. It's all stock even the tune excpet for a iac, gatorback and K&N FIPK, and pcv.
 

·
Admanistrator
Joined
·
13,320 Posts
I guess stop putting in in neutral after hard pulls :tomato
 
  • Like
Reactions: 96SNAKE

·
Registered
Joined
·
327 Posts
Discussion Starter · #11 ·
I guess your right man. There was one time though when I didnt give it a hard pull just driving on the highway gettung on to the off ramp about to take my exit and im cruising in neutral and it died on me. I'm thinking now that maybe its what you said is whats happening.
 

·
N/A 4v Guru
Joined
·
3,484 Posts
I heard a similar problem for the S197's : After travelling at highway speeds for a long period, when you come to a stop quickly after slowing down, the car can shut off. But when it is turned back on, it is fine. I believe it had something to do with the fuel pump. It was pumping at one rate, and the computer didn't adjust for the rapid deceleration and stop quick enough, so the car shut off.


Have you changed the A/F ratio at WOT?
I guess stop putting in in neutral after hard pulls :tomato
Yes this is pretty much what is happening. If you get a good tune it will stop, it's just not made to realy compensate for that with the stock fuel tables.
 

·
Registered
Joined
·
2,182 Posts
i have it sniper tuned....how would you fix tha porblem using the sniper tuner?
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #14 ·
Yes this is pretty much what is happening. If you get a good tune it will stop, it's just not made to realy compensate for that with the stock fuel tables.
Do you think a sct preloaded tune would fix this, man?
 

·
Registered
Joined
·
1,935 Posts
i dont know about the pre-tunes but i had my adusted on the dyno because the Idle would just hang at 2,200 at a light and after about 30 secs it would drop....
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #16 ·
Okay, thanks again. This is a great website, guys. :)
 

·
Registered
Joined
·
2,182 Posts
i dont know about the pre-tunes but i had my adusted on the dyno because the Idle would just hang at 2,200 at a light and after about 30 secs it would drop....
thats what happens to me once in a while, but i think its my throttle body that stays open a lil bit..i have to tap tha gas pedal for tha rpms to go down
 

·
Registered
Joined
·
1,935 Posts
my doesnt do it anymore, the guy and the speed shop said that ford does it to manuals so that people dont kill em at a stop. :dunno
All people cant be that stupid.... :shiftyeyes nvm Whitfang could be lurking
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
Okay, thanks again. This is a great website, guys. :)
No problem, that's what we're all here for. Feel free to stick around and check out other parts of the site :)
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #20 ·
Sure will, thanks! BTW, I love the avatar! LOL!
 
1 - 20 of 74 Posts
Top