Modded Mustang Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter · #1 ·
The was running and turning off just fine prior to all this. I took it to a shop to have it aligned and other work done. it sat for around 2 weeks. When i got it back, i put a new distributor on. I installed the petronix system on it with a petronix coil. I also installed the battary in the trunk and connected the bat ground wire to the rear bumper mount inside the trunk. My problem is that when i go to turn the car over with the key, it turns over just fine but when i turn the key off, the car continues to turn over. I have a brand new ignition switch inside the car. I noticed that the coil also was very very hot after all this and smelt like it was burning...... Can someone help me figure out whats wrong with this.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #3 ·
I got it worked out now i believe mustangone.... The starter seloniod was bad so i changed it out. I installed the petronix ignitor back on and doubled checked it was installed right to the coil. The wire coming from the engine harnes, the 12v source wire, i think its red and green, is the only thing i did not re-connect to the coil. Im not sure just yet if i have spark but i can crank the motor and stop cranking the motor with the key now. I have disconnected the electric fuel pump because i didnt want to start the car just crank it so thats why im not sure if i have spark or not. One problem at a time lol. For the Petronix unit to work, do i need to connect that wire to the coil? if so what side? The coil isnt burning up now so im not sure if that wire was the problem or if it was the bad seloniod?
 

·
Premium Member
Joined
·
2,247 Posts
The red w/green is the switched power for the coil. all that should be going to the coil is red w/green and the red from pertronics to + of coil... and black from pertronics to - of coil.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #5 ·
thanks mustangone..... everything works great now. sending the car to get tuned tomorrow so i wanted to make sure i had all the wires right
 
1 - 5 of 5 Posts
Top