Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,668 Posts
Discussion Starter #1
i go to turn the ignition and all i hear is a ticking. no life from the motor, is this the alternator going out. she's got about 90k of life on her if it's stock, with upgraded stereo on 25k. Radio still comes on so i do not think it's battery guys, thanks this site saves.
 

·
Registered
Joined
·
6,973 Posts
Might be the battery. Mine had enough juice to unlock the doors and when I flipped the key my Raptor shift light did its light up as usual and the radio came on, but it didn't have enough juice to crank.
 

·
I wanna SPRAY!
Joined
·
7,461 Posts
Check the connections on your battery. That sounds like the problem to me.
 

·
Registered
Joined
·
1,428 Posts
I just had the same problem a few weeks back. If you can get it jump started and running you can take a multimeter and see what you get for output on the alternator.

Take the multimeter and checl the DC volts on the battery before jump starting.

Then check the alternator out put voltage. The output voltage should be close to 13 volts.

Once it's running if the battery light is not ON then drive it to an Autozone and have them check the battery and alternator. Or you remove the alternator and they can bench test the alternator.

If it's not the stock alternator take it to a shop that specializes in alternator repair. The reason I say this is Autozone tested my 200 amp alternator and it failed on their tester. I took it to an alternator repair shop and it passed on their more sophisticated tester.
 

·
Registered
Joined
·
646 Posts
Same thing happened to me a few months back. I replaced the battery and added new gold plated battery connectors. Now she cranks like a champ.
 

·
Registered
Joined
·
1,668 Posts
Discussion Starter #10
okay tomorrow my cousin is coming over with jumper cables, and we are going to get it running and then go swap it out for a better one. i appreciate it guys, you save me time and money like always.
 

·
Registered
Joined
·
21,024 Posts
Hey man, did you get those cams in and stuff? If so whens the dyno tune??
 

·
Registered
Joined
·
1,668 Posts
Discussion Starter #12
Hey man, did you get those cams in and stuff? If so whens the dyno tune??
no man that shop i was going to sucks tremendously, i've had the hardest time trying to get this sorted out. the only guy worth a craps out of town for a 1 1/2 weeks so i'm getting my money back for the cams & install and ordering cams myself. i've found another shop in lex, sc that does performance work and trying to get it taken care of. it's been the most frustrating 6 weeks ever.
 

·
Registered
Joined
·
21,024 Posts
Damn that sucks. Good luck with it man. Hopefully it all works out good
 

·
Registered
Joined
·
3,219 Posts
no man that shop i was going to sucks tremendously, i've had the hardest time trying to get this sorted out. the only guy worth a craps out of town for a 1 1/2 weeks so i'm getting my money back for the cams & install and ordering cams myself. i've found another shop in lex, sc that does performance work and trying to get it taken care of. it's been the most frustrating 6 weeks ever.
You may want to call the guys a Pro-Dyno in Fort Mill. They may be able to recomend someone to do the cam install, then take it to Pro-Dyno for the tuning. I've heard good things about them.
 
1 - 14 of 14 Posts
Top