Modded Mustang Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
635 Posts
Discussion Starter · #1 ·
I might have jinxed myself in that "how many miles on your new edge" thread -.-

I pull up to the auto parts store and get out and hear this noise and not knowing what it is but see everyone looking at my car. So I get closer and hear its from the car. So I go in and make it quick so I can get back out to see whats the problem. I popped the Hood and see white smoke coming from the passenger side and still smell this distinct smell.. I look at the coolant levels and there low. So I'm guessing the car overheated?

When I try to crank it it wont even turn over anymore. It has a new starter and battery, could it be the alternator?

I can't check to see if anything is leaking because the ground is wet from rain
 

·
Anandavenkatakrishnan
Joined
·
21,386 Posts
Is your manifold leaking?
 

·
Registered
Joined
·
257 Posts
Something must have leaked if there is no coolant. Pop the hood and check the heater hoses, those are near the passenger side. Is your car a Manual? If it is, try putting it in 4th gear and letting it roll down a driveway. If it moves, your engine will spin over. If it doesnt move, your engine is stuck. Do the normal battery procedure to see if its good. Windows working? Radio? gauge lights showing? Check things
 

·
Registered
Joined
·
635 Posts
Discussion Starter · #6 ·
Guy checked under the car when he towed it and said one of the wires from the starter is messed up, when he touched it, it sparked. I dont see any leaks from the intake manifold and the heater hose looks fine. My driveway is slopped so I cant tell if the coolant levels are back to normal
 

·
GT 4.6 SOHC
Joined
·
270 Posts
Glad to hear

Ohh boy, I was worried when you said the motor wont turn over. I already felt sympathy. Atleast you got to the core of your issue.

Short story! : P

This past Friday, I was out with the family in my 01 GT 2v and stopped at a few different places, kinda the stop for 5 minutes and go kind of thing. Anyways, we went to go get some smoothies and I had just finished telling my wife how great the car was driving after doing a intake manifold change with aluminum crossover, 103 Autolite spark plug change, Injector seals and pintle cap change, coolant flush x 3 > watter wetter, 70/30 coolant to water and all of a sudden; I tried turning on the car and the vehicle could not stabilize. The idle was competely bad, gave it some gas to see if the idle control was bad, but it was bogging through all RPM ranges. I figured it would have to be bad fuel pressure. I know damn well more than one ignition coil would not go bad at the same time, and there was not any CEL. I turned the car off, tried turning it back on and was only turning over. Had it towed home, replaced the fuel pump and it turned on like new again.

Problem is, I know have an EVAP leak with the CEL on.... Ohh boY! lol. :bash:
 

·
Registered
Joined
·
635 Posts
Discussion Starter · #10 ·
Ohh boy, I was worried when you said the motor wont turn over. I already felt sympathy. Atleast you got to the core of your issue.

Short story! : P

This past Friday, I was out with the family in my 01 GT 2v and stopped at a few different places, kinda the stop for 5 minutes and go kind of thing. Anyways, we went to go get some smoothies and I had just finished telling my wife how great the car was driving after doing a intake manifold change with aluminum crossover, 103 Autolite spark plug change, Injector seals and pintle cap change, coolant flush x 3 > watter wetter, 70/30 coolant to water and all of a sudden; I tried turning on the car and the vehicle could not stabilize. The idle was competely bad, gave it some gas to see if the idle control was bad, but it was bogging through all RPM ranges. I figured it would have to be bad fuel pressure. I know damn well more than one ignition coil would not go bad at the same time, and there was not any CEL. I turned the car off, tried turning it back on and was only turning over. Had it towed home, replaced the fuel pump and it turned on like new again.

Problem is, I know have an EVAP leak with the CEL on.... Ohh boY! lol. :bash:
wow! haha luckily i know what it is, my car is gonna be parked for a while. Im buying a small honda until I have enough to work on it. Its gonna come out better than ever.
 
1 - 12 of 12 Posts
Top