Modded Mustang Forums banner

1 - 20 of 44 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Ok. I went out to leave for work this morning and my car isn't starting. All my accessories work (tested radio, interior lights, headlights). When I try to start it, it seems to crank and my radio comes on, but then my battery light comes on and my check engine light comes on as well. Any thoughts?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #4
2001 v6 automatic

when i start it if i hit the gas i can rev the engine, but when i let off then my rpms go all the way down and my battery light and cel come on and it dies...haven't noticed any dimming of lights or headlights
 

·
Registered
Joined
·
107 Posts
Discussion Starter #6
i had an issue previously where they replaced my idle air bypass valve, fuel filter, and flushed my fuel system....think that is clogged up again somehow?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #7
well i was thinking maybe alternater...i'm at 67000 miles currently so it's getting to be about that time...i haven't noticed any of my lights dimming though
 

·
Registered
Joined
·
107 Posts
Discussion Starter #8
or would i have to crank it until my battery got low for my lights to dim?
 

·
MM's Resident Ricer
Joined
·
9,892 Posts
manual?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #10
automatic
 

·
MM's Resident Ricer
Joined
·
9,892 Posts
so it will rev but not turn over? does it crank start to idle and die out
 

·
Registered
Joined
·
107 Posts
Discussion Starter #12
well from just turning the key, it won't idle at all. once i let off the key it just dies and battery light and cel come on....if when turning the key i step on the gas i can rev the engine, but it will die right away again when i let off the accelerator
 

·
MM's Resident Ricer
Joined
·
9,892 Posts
can you hear denotation when you rev while starting it? and does just the bat and cel light come on or all of them?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #14
just the battery and cel come on...when i rev it i believe it is detonating, but it still doesn't sound quite like it normally does
 

·
Administrator
Joined
·
83,767 Posts
So are you saying the car starts, and runs, but won't idle on it's own, and dies if you let off the accelerator?

Or will it not run even with your foot on the accelerator?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #16
well i haven't actually tried to go anywhere...i suspect i might be able to move it a little if i had to...if i step on the gas while turning the key i can rev the engine and as long as i keep revving it my trouble lights don't come on...it dies immediately though when i let off the gas then the trouble lights come on

edit: it won't start just turning the key...it will try but won't turn over on its own..tries to start then won't and bat light and cel come on
 

·
Administrator
Joined
·
83,767 Posts
Sounds like the IAC went bad. That's your Idle Air Control sensor.

When it's running with your foot on the accelerator, how does it run? Smooth without any odd noises?

Do you notice any smells, like a heavy smell of gas from the exhaust?
 

·
MM's Resident Ricer
Joined
·
9,892 Posts
its your battery if you have denotation if you dont suspect IAC
 

·
Registered
Joined
·
107 Posts
Discussion Starter #19
IAC connects to upper intake correct? if so, that has been replaced about a year ago...if that is bad again there has to be something else causing it i would imagine
 

·
Registered
Joined
·
107 Posts
Discussion Starter #20
it could still be battery even though all my accessories work w/o the car running? i can turn on interior lights and headlights and can run the radio as well
 
1 - 20 of 44 Posts
Top