Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
so i got a 99 mustang 2 weeks ago and a week later i was leaving work and it wouldnt turn on. so i got it toed to my mechanic and the first thing we did was put in a new fuel pump.. that didnt work. the theft light was blinking so we got a new part for that but now we need to get it programmed from the ford dealer. do you think this will solve it when its programmed? or is there anything else you can think of that would do this? thanks.
 

·
Tree Fiddy Z
Joined
·
2,040 Posts
i'd check the basics...spark plugs, wires, and make sure the injectors aren't clogged. Check to make sure the battery has enough cold craking amps. Just thought about it...but I'm assuming your mechanic replaced the fuel filter too. All this is assuming the car sounds like it wants to turn over...it doesn't.
 

·
Rainbows Mechanic
Joined
·
1,612 Posts
if the car wont turn over at all check you battery terminals and make sure there clean and tight...also your starter maybe ha...theft light...try hitting the unlock button on your remote twice and try starting it...
 

·
Registered
Joined
·
2,138 Posts
if the car wont turn over at all check you battery terminals and make sure there clean and tight...also your starter maybe ha...theft light...try hitting the unlock button on your remote twice and try starting it...
after the alarm goes off and the theft light blinks real fast, start the car and let it cycle once. By cycle i mean turn on let hea tup to operating temp and then turn off.

Thats what ive noticed when mine stops.
 

·
MM's Resident Ricer
Joined
·
9,892 Posts
check your ignition fuse
 
1 - 6 of 6 Posts
Top