Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,400 Posts
Discussion Starter #1
hey whats up guys long time no talk ive been super busy with school and such but need a little insight on some codes im getting

most of you know i blew my motor on Halloween, well i had it replaced with a new one from a 97 with 63k on it. after about a week the car would shut off, found that problem and it was a bad cam sensor. so i replaced that and the car run fine, until just recently the car threw a p4020 code a while back late june to be exact. i have been driving it ever since well its starting to act up know. ive had numerous people tell me its the cats, i dont think it is since its not throwing the code anymore. im getting 1132 1131 and 1151 which are 02 senors the car seems to sputter at wot and when taking off from stops, im also getting a rattle too, and the car loses power then quickly regains it while driving (fuel filter is brand new) i figured i would let some of you help me before i start buying 02 sensors left and right
 

·
Registered
Joined
·
390 Posts
pull them out, torch and test them or swap the front with the back. didnt you have the thread about high fuel consumption? i have delt with bad fuel economy and i know it can clog up the cats. if you have your window down and you smell rotten eggs "sulfur" under hard acceleration your cats are partially plugged. give it hell and they may or may not open up some depending on how far off the injector open time is.
 

·
Registered
Joined
·
2,400 Posts
Discussion Starter #3
pull them out, torch and test them or swap the front with the back. didnt you have the thread about high fuel consumption? i have delt with bad fuel economy and i know it can clog up the cats. if you have your window down and you smell rotten eggs "sulfur" under hard acceleration your cats are partially plugged. give it hell and they may or may not open up some depending on how far off the injector open time is.
nah i didnt have that thread but last week i had to fill up at least 3 times. i live never let on it E 20$ gave me about 3/4 of a tank and i put in on Thursday drove 100 miles and the car was on 1/4 of a tank. the injectors are brand new.
 

·
Registered
Joined
·
390 Posts
dont swap front and rear o2s, just checked mine and they are infact different part #s.
hanes book says p0131: upstream Ho2 circuit low voltage [bank 1].
p0132 it doesnt list.
p0151: upstream Ho2 sensor circuit low voltage [bank 2]

you needs new o2s or you can pull them and torch the hell out of them "with propane nothing else" and use wire brush to clean. i have succesfully restored the ford NTK o2s numerous times by torching them red. all of my o2 sensors have more then 250K miles and they work better than brand new bosch o2s. Most garages wont waste thier time cleaning a testing them to save you $$$.
 
1 - 4 of 4 Posts
Top