Modded Mustang Forums banner
1 - 14 of 14 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey guys im new to the mustang world. i just bought my first 2000 ford mustang gt. So far I have a jlt intake, x pipes without cats, and flowmasters. My problem is that when i first bought the car with all the upgrades it did 160 miles before going on empty now ive noticed it did 210 miles before going on empty and also the check engine flashes? if you guys can help me out here that would be great :confused:
 

· Priest of the Car Gods
Joined
·
22,072 Posts
If the CEL is flashing, download the codes. If you're too broke to buy an OBD2 Scanner (less than $100), go to autozone, most will scan the codes for free.

Regarding the mileage, has your driving changed? Most people wouldn't complain about their gas mileage increasing, hahaha.
 

· Billy Weston
Joined
·
6,727 Posts
A flashing CEL means the computer has picked up a misfire. You're going to want to stop driving it until you figure out the issue.
 
  • Like
Reactions: Thumbie

· Registered
Joined
·
2,235 Posts
does that mean there is a missfire, nothing else? well the lack of cats, unless it had mil eliminator's would throw a code. and there could be a number of things leading to misfire, goodluck with that :p
 

· Premium Member
Joined
·
11,000 Posts
A flashing CEL means the computer has picked up a misfire. You're going to want to stop driving it until you figure out the issue.
+1, anytime the CEL blinks it means that there was either a misfire or multiple misfires and you need to get them checked out ASAP
 

· Registered
Joined
·
1,515 Posts
If the CEL is flashing, stop driving the car asap! I forgot where I read it, but it means one of your cylinders is misfiring. Don't drive the car until you get it fixed!

[EDIT]

Looks like I was beaten to the punch.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
i went to autozone and found that the computer was reading that there was a misfire on cylinder #5. went and removed the spark plug cable and found that there was water inside were the spark plug sits. i dried all the water with a blow dryer and car runs better than ever .....never again cleaning the engine with "engine cleaner" and water.thanks guys for all the help
 

· Registered
Joined
·
1,515 Posts
Just curious, how long have you been running the engine like that?
 

· Registered
Joined
·
34 Posts
ya dude dont worry bout it, my car does the same ****ing thing, ran a brand new engine while it was misfiring for like 3 weeks, no damage done. I had the same problem, power washed the engine and got water down the holes, i also have a bad fuel pump which makes it misfire sometimes
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top