Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,930 Posts
Discussion Starter #1
my clutch is engaging almost at the top of the pedal travel.
it is a CF DF clutch and its 3 years old. i realize this clutch doesn't hold too much HP.
when it does engage it holds well, but just grabs really high on the pedal travel.
it is the stock slave cylinder, it goes into and out of gear just fine.
i also have a Whipple SC with 449 rwhp/ 419 tq. its not my DD, but i do get on it when i drive it sometimes.

is there a way to adjust the pedal travel, or do you think my clutch is starting to go and i should just replace it?
 

·
Insomniac
Joined
·
5,912 Posts
The hydraulic clutch is self adjusting but it is possible the slave cylinder might be going and countless people swear by oem slave cylinder over aftermarket.
 

·
Registered
Joined
·
1,930 Posts
Discussion Starter #3
how could i be sure its the slave cylinder?
it is a little difficult to get it into reverse. sometimes worse than others.
also have a pro 5.0 shifter, but i doubt its that bc other than the clutch pedal its ok.
 

·
Registered
Joined
·
1,458 Posts
mine engages at the top as well but it works fine too
 

·
Registered
Joined
·
1,930 Posts
Discussion Starter #5
over time it slowly got worse.
and i dont think its getting better.
 

·
Yut Yut Devil Dog
Joined
·
4,591 Posts
My OE clutch started to do that over time. And as you said, it got worse over time. I took it to my tranny shop, and just replaced it. I honestly don't know if it was the clutch, or the bearing or what. It works now... lol.
 

·
Resident Diabetic...
Joined
·
1,827 Posts
I know on the non hydrolic clutch sn95 mustangs everyone swears on the ford throw out bearings over any else. Which is true in my personal experience. Should I assume the same applies here? And where do y'all buy them from?
 
1 - 7 of 7 Posts
Top