Modded Mustang Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter #1
1995 Ford Mustang GT 5.0

Clutch: I have a problem that's being caused by clutch cable being stretched. I don't want an FireWall Adjuster either
Question: Is there a way to adjust the stock cable (without lifting the peddle, because I tried that)? or do I need to replace it?

Rear End Shifting: I got my upper control arms replaced with a used stock Cobra pair. The problem is still there and happening after I replaced them. I then figured that it was my shocks because they're blown. I just replaced the Rear Shocks, Rear Dampers, Front Shocks, Steering Rack Bushings and then an alignment. The problem is a little better, but it's still there of course.
Question: What else could it be?

What I mean by shifting is like, you move the steering wheel left to right without turning. Then the rear body will move left to right, do it to hard and it will lose tracting and through it's self off. Same thing happens when you take a fast sharp corner. If you park the car and push the rear of the body, it'll move, but not sure how much. I only noticed this when I got new tires and got bigger tires. I went from 245/45/17 to 275/40/17 in the rear.
 

·
Registered
Joined
·
96 Posts
im pretty sure the only adjustment on a stock clutch is pulling the pedal up towards you then back down.. and i dont know about the rear end problem but it sounds super sketchy!
 

·
Registered
Joined
·
224 Posts
Discussion Starter #3
What does a Quadrant do? Besides being used for an adjuster, from what I read.

im pretty sure the only adjustment on a stock clutch is pulling the pedal up towards you then back down.. and i dont know about the rear end problem but it sounds super sketchy!
I mean I can drive it normally, but when I'm on a highway it's could get really bad. But the fact I know it's there and I can't find out the problem, it bugs me.

I figured I'd have to replace my clutch cable, but I've heard so many cables snapping and I don't know what one to go with.
I was thinking of this one, since it has good reviews:
Maximum Motorsports High Performance Clutch Cable (82-04) at AmericanMuscle - Free Shipping!
 

·
Registered
Joined
·
96 Posts
ya dealerships will tear you a new asshole! but i havent had to replace my cable yet so i havent done much research on it.. hopefully somebody will chime in and help you with getting the best one..
 

·
Registered
Joined
·
224 Posts
Discussion Starter #7
ya dealerships will tear you a new asshole! but i havent had to replace my cable yet so i havent done much research on it.. hopefully somebody will chime in and help you with getting the best one..
Yeah I hope so, I've been without my car for a week or longer. The other forum is beyound dead and I got tired of waiting, so I came here. I was supposed to get another vechile today, but plans didn't workout. So now I'm left dumping money into my car. :/
 

·
Registered
Joined
·
627 Posts
i dont know on the 95, but on my foxbody there is a nut at the end of the clutch cable where it attaches to the fork. if i turn the nut it will tighten the cable or loosen it if i turn the other way.
 

·
Registered
Joined
·
11,200 Posts
maybe your coil springs are shot:dunno
 

·
Registered
Joined
·
224 Posts
Discussion Starter #10
i dont know on the 95, but on my foxbody there is a nut at the end of the clutch cable where it attaches to the fork. if i turn the nut it will tighten the cable or loosen it if i turn the other way.
Yeah mine doesn't have that, I wish it did. :( I don't mind so much getting another cable, but I don't want to go blowing money on a cable that's going to snap on me. The link I posted, seems to have legit reviews.

I meant to put this in the Sub Form, but I didn't notice it util later on. I'm used to posting in General Talk, on the other forum. Mods don't seem to care that I posted it here. :/ haha

maybe your coil springs are shot:dunno
That's very possible, I never thought of that. If that was the case, wouldn't the ride feel like ****? Because with the new shocks and stuff, it rides amazingly, a little to stiff, but oh well. I will mention this to my mechanic, thank you.

How can I check to see if the Springs are shot?
 

·
Registered
Joined
·
11,200 Posts
this is what happen when your thread gets moved.....The thread just fades away
 

·
Registered
Joined
·
11,200 Posts
what about the rear end ? did you figure that out ?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #14
what about the rear end ? did you figure that out ?
Oh yeah, I know what you mean. It seems this forum is really dead. I had them move it since my car isn't a Fox Body and the parts are completely different.

Yeah that's what I meant by finding out my problem. I am 101% positive it's my lower control arms, they're moving back and fourth inside where they mount off. If you look on the side, you can see bare metal from it rubbing on it and what not. I still may be wrong, because I'm still learning, but from the looks of it and the theory I have behind it, it seems to be the problem.

I took a bunch of pictures if you'd like me to upload them.
 

·
Registered
Joined
·
4,875 Posts
Upload em. It's always good for when someone else has a problem and goes searching through the forum. Make sure to post up when you fixed the problem and verify that was it too.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #16
Upload em. It's always good for when someone else has a problem and goes searching through the forum. Make sure to post up when you fixed the problem and verify that was it too.
That's very true too. It might be awhile for me to fix them, as they're not important to me yet. I just need to find a place to buy the bushings and other stuff for the lower Contronl Arm, unless it's cheap then it might come sooner. I know when I'm doing that I'm going to replace the Isolators with new ones.

I will upload them in a bit or sometime today. I'm not really sure you can even tell or see, I just wanted to take pictures of them before the process. haha
 

·
Registered
Joined
·
224 Posts
Discussion Starter #19
This took longer than I expected and I didn't realize I took so many pictures.


I am 101% positive it's my lower control arms, they're moving back and fourth inside where they mount off. If you look on the side, you can see bare metal from it rubbing on it and what not. I still may be wrong, because I'm still learning, but from the looks of it and the theory I have behind it, it seems to be the problem.


This is the Passenger Rear Lower Control Arm:










Is this the Torque Box?
 
1 - 20 of 20 Posts
Top