Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have a 96 cobra. It pulls strong through all of the gears from take off through 5th. But if I am driving on the freeway, doing freeway speeds (65 or 70 mph), in 5th, and step on the go peddal, the RPMs go up but there is no increase in speed. I am sure I am not breaking the tires loose. The car is stock. No way a stock mustang cobra will break the tires loose in 5th on the freeway.

Time for a new clutch? If I needed a new clutch would I not feel it when I am in 1st leaving a stop? It works great, pulls strong, from launch. If it were the clutch would I not get slippage at launch?
 

·
Registered
Joined
·
171 Posts
i may be reading this wrong but it seems kinda normal to not have any go power in 5th gear its a cruising gear. or am i reading that you have absolutely no speed gain like at all??
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
i may be reading this wrong but it seems kinda normal to not have any go power in 5th gear its a cruising gear. or am i reading that you have absolutely no speed gain like at all??
What I am saying is that I step on the go peddle, without changing gears, and the RPMs quickly go from about 2000 RPMs to 5000 RPMs and there is no increase in speed.

Something is slipping. I have to guess it is the clutch. As I am not aware of any other part in the system to slip. To my knowledge it is a direct system through the 5 speed tranny, the drive shaft, the rear end, to the wheels.

But I do not have slippage on launch or the other gears. It would seem to me that during launch is when there is the most pressure on the clutch to slip and yet it is strong.
 

·
Registered
Joined
·
470 Posts
Thats weird so when u step on the gas the rpms just launch up like you were revving in neutral or something but no power goes to the wheels. Does your car cruise in fifth gear up untill you get to that 65-70 mark?

From what you said it almost sounds like the car isnt even in 5th gear at all if the RPM's launch like that. For my car sometimes when i put it in reverse and i even hear my short shifter make a clicking sound like its in reverse and the shifter stays in place it doesnt bounce back as if i missed a gear or something and i let the clutch out and hit the gas i hear a horrible grinding sound with my rpms revving high, my car doesnt move since it didnt fully engage reverse so i just try again and it will usually fully engage reverse and get me moving but this only happens maybe once a month. Almost sounds like someone did this to your car only in 5th gear and they completly grinded it down to where it doesnt even make the grinding noise anymore cuz there is nothing left to grind and its not fully engaging 5th gear. I dunno just theory and my 2 cents.
 

·
Registered
Joined
·
171 Posts
does it do the rpm jump if you are in 5th gear at a lower speed and try to speed up try that if the rpms jump it could just be your gear cause it seems like the rpms would do that in every gear if the clutch is slipping.
 
1 - 5 of 5 Posts
Top