Modded Mustang Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
I just put a new spec stage 3 clutch in my car and drove it for about 100 miles and I am hearing a squeaking noise when I put my foot on the clutch pedal. Does anyone have an idea of what it could be.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #3
no the kit came with a new one.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #4
i Mean i bought one when i bought the clutch kit.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #6
no actually i didn`t put the quadrant on, but i didn't think that it would have caused the squeaking noise.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #9
yeah i know but i replaced the t/o bearing when i put the clutch in.
 

·
Registered
Joined
·
1,055 Posts
did you use a clutch alignment tool? and did you adjust the clutch properly? also install that quadrant...one more thing....what possesed you to buy a stage 3?
 

·
Registered
Joined
·
266 Posts
Discussion Starter #14
I am pushing 540 rear wheel torque and just wanted plenty of clutch to back it. I figured since i was doing a clutch job i would go ahead and get a strong one. It is just the stage 3 not the stage 3+.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #16
B/c it is my brother car it is an 2003 mustang cobra not a 2002 mustang gt.
 

·
Registered
Joined
·
1,930 Posts
Oh thank goodness.. I was thinking I was about to have to replace it. PITA!!
actually, im pretty sure it is something to worry about.. don't remember specifics but i read it in a thread on here.. it can have adverse effects if left without being fixed for a while.. correct me if im wrong someone
 
1 - 17 of 17 Posts
Top