Modded Mustang Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Well my car has been running like crap for a awhile now and when I started it up today it threw code po300 which is random misfire detected, what would this be and where should I start looking at to correct the issue ?


Thanks
 

·
Semper Fi
Joined
·
4,181 Posts
^^yup
 

·
Registered
Joined
·
3,680 Posts
what modifications do you have?
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
I have hot rod cams, delete plates, jlt cold air,steeda udp's, 100 shot nos, hto plugs, xcal 3 with vmp tune, off road mac pro chamber, 4.30 gears.


I have changed my plugs 3 times and still runs the same.
 

·
Semper Fi
Joined
·
4,181 Posts

·
Registered
Joined
·
3,680 Posts
has it just started this and ran fine on the plugs you changed 3 times?

could be a damaged cam position sensor, crank postion sensor or bad coil(s)

I'd suspect something didnt go quite right with the cam swap...
 

·
Registered
Joined
·
72 Posts
Discussion Starter #9
has it just started this and ran fine on the plugs you changed 3 times?

could be a damaged cam position sensor, crank postion sensor or bad coil(s)

I'd suspect something didnt go quite right with the cam swap...
It has been running like crap for a while, that is why I changed my plugs each time just to see if that was the problem and it always turned out not to be the problem. This was the first code it has thrown, but I have lost about 2 miles per gallon here the last few months.
 

·
Registered
Joined
·
3,680 Posts
check your o2's too.. do a datalog
 

·
Registered
Joined
·
72 Posts
Discussion Starter #11 (Edited)
check your o2's too.. do a datalog
Think the O2's could cause a problem like this ? The reason I say it runs bad is it has a bad miss or stumble between 1500 - 3500 rpms but still seems to pull hard at WOT. And the smell of the exhaust has changed to a real real rich smell.
 

·
Registered
Joined
·
3,680 Posts
oh yes o2's can cause a misfire.... like I said do a datalog.. make sure the front o2's are ocilating... should be peaking around 850-920 mV's @ wot.
 
1 - 12 of 12 Posts
Top