Modded Mustang Forums banner
1 - 6 of 6 Posts

·
Still slow.
Joined
·
8,738 Posts
Discussion Starter · #1 ·
So i decided to find out why i had no speedo and why my car kept stalling out on me the other day. Jacked it up on 4 stands and turns out someone cut half the o2 sensor cable and the speedo cable right were it goes into the tranny is half burnt and half cut.:confused:
 

·
Registered
Joined
·
470 Posts
thats blows sounds like you got some enemies or one angry ex girlfriend :O
 

·
Registered
Joined
·
470 Posts
Well with girls u gotta factor in the hotness to crazy ratio, hotter they are the more crazy but i dont think a chick is smart enough to get under there and clip some wires, they are more into cosmetic damage >.< I dunno if you have your exhaust done but maybe some angry neighbors dont like your loud exhaust waking em up every morning and the basterds thought they could do something about it. Fcking haters... atleast u can wire the o2 sensors back together and cover em up with electrical tape, i dunno jack about speedo cables so you'll have to chime in on that fix when you get er done. I ended up wrapping my o2 sensors in elec. tape since the wire cover on there doesnt cover the wires all the way end to end.
 

·
Still slow.
Joined
·
8,738 Posts
Discussion Starter · #5 ·
Well with girls u gotta factor in the hotness to crazy ratio, hotter they are the more crazy
I hate how true that is.:crazy

To be completely honest i think the o2 was chewed off by a chipmunk or something, but the speedo i have no idea.:dunno
 

·
Rollin' 18/ pushin' 2
Joined
·
8,333 Posts
Did you maybe run over something that could have caused the damage?
 
1 - 6 of 6 Posts
Top