Modded Mustang Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2,182 Posts
Discussion Starter #1
So my car be acting funny, recently my windows wont go down or up and my driver side lock and unluck button dont work or my side mirror adjuster, tha only thing that works is tha unlock and luck button on tha passanger side

this is happening alot, sometimes everytinng works fine and den with my windows down they wont go back up...this is pissing me off y is this happening? thanx for help
 

·
Premium Member
Joined
·
10,464 Posts
pull the door panel off and see that the wires leading up to the switches didnt get pulled or snagged. I had this happen in my old fox where whenever i rolled the windows down it would snag the wires and cut them.

does this only happen when you roll the window down?

If all the wires and plugs check out then start looking into fuses but im willing to bet if they all went out at the same time then its got to be something with the plugs/wires.
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #3
its weird sometimes they wont even go down, sometimes they will, other times they work perfectly, tha only thing that never fails is tha passanger side luck button
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #4
wen they get stuck open, i have to park tha car for a while then we i turn it on they roll back up, and other times tha car has to be on for them to work i cant just turn tha key back, and vise versa
 

·
Registered
Joined
·
583 Posts
damn mustangs and their electrical problems. they are notorious for **** like this...mine has acted up a whole lot
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #6
any fixes
 

·
Registered
Joined
·
583 Posts
Well i blow fuses left and right. I had a 7" flip out touch screen in my car hooked up to a 350 watt amp and 2-10" JL's. Sold the system - the amp and subs - and i was on my way back from savannah one night with my windows down...turned the volume up to like 24 on the touch screen and bam...fuses blew like it was cool. Couldn't roll my windows back up till the next day. And now...when you turn my nob to the maxac setting...the **** blows out at your feet. It's an electrical problem im sure because some days it'll blow out at your face where its supposed to and other days it will come out at your feet. I said screw it and havent messed with it...pisses me off though
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #8
**** this sux i dont wana roll around with open windows then all of a sudden i cant put them up wen im town doin stuff, thiefs, weather, this is bad
 

·
Registered
Joined
·
583 Posts
**** this sux i dont wana roll around with open windows then all of a sudden i cant put them up wen im town doin stuff, thiefs, weather, this is bad

yeah i was really worried that night...luckily the 3 day straight rain showers stopped the very day my windows decided not to function
 

·
Premium Member
Joined
·
10,464 Posts
check your fuses to see if anything is blown, check the wires in the door, check all connections, and go from there. It could be as simple as the buttons just not working, which my p/s window would do until I swapped out switches. You just need to find out what you can so that we can try to guide you in the right direction on what to do.

As far as mustangs having electrical issues I havent really heard too many with huge electrical problems. By the way that it sounds if all that stuff started happening after you got a system installed then it sounds to me that someone screwed something up as ive worked on many vehicles and that has never happened:2cents
 

·
Premium Member
Joined
·
10,464 Posts
I saw that. The reason why I assume that it is an installers screw up is because you stated that the hvac does not function properly which is directly underneath the 7" screen that you had installed. If all this started happening either after you got it installed or after you had taken it out I would assume that somewhere in the process something happened seeing as everything is in that general vicinity of where you screen is. Even if you did leave the screen in, unless you left the RCA's in there, you still need to access behind the radio in order to remove the rca's and remote wire that is ran to turn the amps on.

Not trying to argue or anything im just stating what I think the problem with your scenario is
 

·
Registered
Joined
·
583 Posts
yeah i know your trying to help man...im not arguing either. ive tried a bunch of **** to figure this problem out but nothing seems to work. sometimes it'll work fine and other times it'll just blow out on the floor. the touch screen has been out of the car for a little over a month now with the stock shaker500 deck back in
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #14
**** i hope its tha switches, but dam both going bad at tha same time, tha odds?...crap
 

·
Registered
Joined
·
1,393 Posts
I would check fuses, and all electrical connections that could possibly contribute, including pulling the radio and comparing the harness to an electrical schematic for your car. You'd be surprised how easily accidently switching 2 wires is, especially when you don't have good enough light to easily distinguish the wire colors. I would especially check all the crimp on connectors, since they are so easy to under crimp without the proper tool.
 

·
Premium Member
Joined
·
10,464 Posts
**** i hope its tha switches, but dam both going bad at tha same time, tha odds?...crap
it might just be. i had my passenger side go out then replaced it, then a year later my drivers side went out and I replaced that. The only reason why I am suspecting a connection problem or your wires being pulled is the fact that all of them went out at the same time.

Question, when they go out and then you have to turn the car off do you stay in the car or get out of the car? Reason for me asking is that opening and closing the door could be causing wires to pull apart and then get pushed back together. Just check all the wires and plugs in the door, jiggle them around, pull on them, inspect them, and then go from there.
 

·
Registered
Joined
·
2,182 Posts
Discussion Starter #17
dam hopefully its my switches...illl check out connections
 
1 - 17 of 17 Posts
Top