Modded Mustang Forums banner

1 - 9 of 9 Posts

·
The George Forman of Keepers
Joined
·
2,356 Posts
Discussion Starter #1
Its been having a problem for about the last month. It only happens on occasion. Sometimes it runs perfectly smooth for days with no problem. Then out of nowhere, it runs rough at stops when in gear. The RPM gos up and down erratically surging and will sometimes stall. It always starts right back up though. It almost seems to be a vacuum leak but I thought I'd get some opinion first. No CEL either. Temperature is normal as well.

It seems to happen more often under load at stops. Its never done it while cruising even at low RPMs. Only happens at stops. In fact, sometimes it does it then I hit the gas to go and it smooths right out like nothing is wrong.

Any idea's or suggestions to check???
 

·
King of Clubhouse
Joined
·
5,277 Posts
Sell it because it didnt have much oil in it.....


Dunno could be a vacuum leak I dont think its that though it would rough idle all the time and die.

Fuel filter possibly? Could be clogged up....
 

·
Retired MM Ninjas
Joined
·
12,556 Posts
I would start by changing the fuel filter, then work you way to the EGR Valve. My 07 Dakota used to do that all of the time. I ended up finding out that the fuel pump was bad.
 

·
The George Forman of Keepers
Joined
·
2,356 Posts
Discussion Starter #6
This truck has a "non servicable" fuel filter. That sucks. Thats usually an easy thing to replace on cars. The truck is pushing 70k miles so its probably due. It looks like thats a dealer thing.
 

·
Registered
Joined
·
812 Posts
fuel pressure regulator? sounds like the same thing that happend to my 93 ford probe, $70 fuel pressure regulator
 

·
Admanistrator
Joined
·
13,320 Posts
id replace/check the O2 sensors. my jeep had a problem a few months ago that sounds like the problem you're having, and it was the O2 sensors that were causing the A/F ratio to go up and down.
 
1 - 9 of 9 Posts
Top