Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I have an '89 LX 5.0, and was hooking up a radio (I put in radios without any problems), and the dash lights went out. Checked the fuse and it's fine. The dome still comes on when I turn the dimmer, but no dash lights. Removed the radio. Still nothing. I pulled the radio fuse, put it back it and it makes a noise near where the radio was whenever i put take it out and put it back in again. The noise sounds like a spark, but I see no spark. Any idea guys?
 

·
Registered
Joined
·
4,875 Posts
The dimmer switch went bad on my car.. might be a possibility. I would also check every fuse with a test light just to be sure you arent missing anything.
 

·
King of Clubhouse
Joined
·
5,277 Posts
I have an '89 LX 5.0, and was hooking up a radio (I put in radios without any problems), and the dash lights went out. Checked the fuse and it's fine. The dome still comes on when I turn the dimmer, but no dash lights. Removed the radio. Still nothing. I pulled the radio fuse, put it back it and it makes a noise near where the radio was whenever i put take it out and put it back in again. The noise sounds like a spark, but I see no spark. Any idea guys?
I used to work for circuit city and I worked on radios this happened to one of the guys once and somehow (hes still not sure) he yanked on one of the wires that yanked on one of the wires behide the dash which pulled the dash lights wire lose I forgot what type of vehicle it was but he said he jsut had to plug it back in just My oppion

Did you multimeter the wires for constant, ground etc? Maybe there was a wire from the dash lights down there somehow and it touched another wire? causing it to short out?
 
1 - 3 of 3 Posts
Top