Modded Mustang Forums banner

1 - 20 of 73 Posts

·
Registered
Joined
·
7,186 Posts
Discussion Starter #1
ok went to the dyno and did an all motor pull and 2 nitrous pulls

made 282hp and 315 tq on motor...80 degrees outside with some good humidity i'm assuming (its SC)

and made 378hp and 415tq on the spray...mods are in garage

the a/f has an average of 11.5 as you can see so its pretty darn safe...

bottle pressure was only 900-950 psi so i think it could have made around 390hp and 430tq with about 1000-1050 psi...

anyway here are the charts...notice how there is no lean spike :D. the microedge is awesome...afr was reading almost dead nuts so very happy with that and the other features





 

·
Registered
Joined
·
7,186 Posts
Discussion Starter #2
just noticed that you can't even see the lines lol...i'm gonna rescan these so you can see them better...

give me a few minutes
 

·
Registered
Joined
·
1,212 Posts
I can see it pretty well. Nice numbers man. Nitrous did you well.
 

·
Registered
Joined
·
7,186 Posts
Discussion Starter #6
thanks guys. i am indeed happy..

maybe its just my comp but here is the chart traced with marker to ease the eyes





 

·
Registered
Joined
·
7,186 Posts
Discussion Starter #8
nx plate kit...

like i said i think if i would have done the run at 1000+ psi i think it would have made 390/430...or somewhere around there.
 

·
Registered
Joined
·
21,024 Posts
Nice man congrats. Makes some sweet torque even on motor. Now get a video of that bitch asap!
 

·
Registered
Joined
·
4,836 Posts
What RPM did you start spraying and what kind of dyno?
 

·
Registered
Joined
·
7,186 Posts
Discussion Starter #14
no longtubes...they are waiting to go on with my tubular k

window switch is set to 3050 so around 3k rpm's...and the dyno is very similar to a dynojet the guy said...i honestly can't remember what he called the dyno
 

·
Registered
Joined
·
4,836 Posts
I was gonna say you might be able to spray a tad lower to up your WTQ #'s but you spraying that low i would not go any lower. I sprayed at 3,400 rpm's @ 950 PSI, if i had sprayed at around 3,200rpms and 50 PSI higher at the recommended psi for the plate system i should of been at about 500 wtq. So it does not really spin to bad? Do you have the nitrous progressor on or something?
 

·
Registered
Joined
·
7,186 Posts
Discussion Starter #16
it doesn't spin at all. even in first. i'll make a vid today. not using the progressive controller
 

·
Proud American
Joined
·
11,288 Posts
it doesn't spin at all. even in first. i'll make a vid today. not using the progressive controller
Lucky haha mine lights the slicks up on the dyno
 

·
Bringing Yellow Back
Joined
·
10,928 Posts
hmm. this is really making me what spray lol

( and cams )
 
1 - 20 of 73 Posts
Top