Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Wax on, Wax off
Joined
·
7,738 Posts
Discussion Starter #1
I ordered a 10000k Bi-Xenon HID kit from this company recently.

The first problem was shipping. I understand they had a holiday, Chinnese New Year, but after that, 2-3 day shipping took 6 days because it was UPS SAVER, not UPS EXPRESS.

After it finally got here, I installed the kit. I hooked up everything the way it should be, with problems all over. From the connecting clips breaking to prongs in connectors not angled right from the start. After installed, turn em on, hear the bulbs move, and.... nothing. No light what so ever.

The company takes exchanges, not refunds.... so BUYER BEWARE of FlashPlus/ VVME/ HID Wholesale...
 

·
Wax on, Wax off
Joined
·
7,738 Posts
Discussion Starter #2
Alright, so I was the one mistaken. :eek:

The relay to ballast connecters were turned the wrong way. Switched me around and boom, HID lighting.

So, VVME did what they said they would do. However I still give them bad points for customer support and shipping.
 

·
Achieving more N/A power!
Joined
·
3,156 Posts
I am thinking of buying a bi-xenon kit from them. There are two other guys on here that I know of that have bought from them as well, they both stated that shipping took a while but other than that no problems.

So it took six days for you to get it from the day you ordered? I would think thats pretty decent since I believe they're coming from Japan. I've heard it takes up to two weeks to receive stuff from them. But, for the price, I would wait that long.
 

·
Wax on, Wax off
Joined
·
7,738 Posts
Discussion Starter #4
no, 6 days after the week holiday, so 13days... BUT there auction said 2-3days and it was alot longer.

Regardless, it works. Only prob I am still having is the bulb is so big on one end so I cant secure the bulbs tight. Therefore my light move alot when driving. I can see them bouncing off road signs and such.

I think im just gonna replace the bulbs with some different ones.
 

·
Achieving more N/A power!
Joined
·
3,156 Posts
no, 6 days after the week holiday, so 13days... BUT there auction said 2-3days and it was alot longer.

Regardless, it works. Only prob I am still having is the bulb is so big on one end so I cant secure the bulbs tight. Therefore my light move alot when driving. I can see them bouncing off road signs and such.

I think im just gonna replace the bulbs with some different ones.
Do you have the stock headlight enclosures?
 

·
Achieving more N/A power!
Joined
·
3,156 Posts
I ordered a 6000K kit from vvme.com (10000K?? You're getting pulled over!)

I didn't order on a holiday, and even coming from Beijing, China (per the return address label) I had it within a week. I ordered it knowing that shipping might take over a week but was pleasantly surprised when it showed up so fast. Installed everything OK, instructions were lacking, but from what I've read almost all HID kits don't have great instructions. Now I just have to figure out how to wire a kit into my foglights!!
 
1 - 6 of 6 Posts
Top