Modded Mustang Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
so, i have a 95 gt, and the problem is this:

i charge the battery to full charge, all the electrics work, and when i turn the key to the ignition position, everything dies. all the electrics stop working. when i pull the key out, the lights come back, but the power doors or windows no longer work.

i can take the battery connections off, and all the electrics come back on. but the same just happens again. the starter motor is new (within the last 6 months) and the battery was on a charger and is working.

my question is this:

what in the world could it be!!!??? i noticed that my positive battery cable connector is split almost all the way through, and sparks when i connect it.

sorry for the long post, and if anyone could help me, i would LOVE it.
 

·
Resident Headbanger
Joined
·
2,432 Posts
what in the world could it be!!!??? i noticed that my positive battery cable connector is split almost all the way through, and sparks when i connect it.
You've found the problem. Replace the connector.
 

·
Better than Drugs!
Joined
·
2,064 Posts
any luck yet? Sometimes on a lowered car the wiring under the drivers fender touches and wears through causing all kinds of problems. Check it out. Even non lowered does it too, just depends how hard you hit bumps lol
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #6 ·
hmm ill have to take a look at that its lowered about 1.25 inches. sadly i work fir the next three days, so i wont be able to try it out.
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #7 ·
sucsess! yea it was the battery connector. i replaced the cap and rotor while i was under the hood, and shes runnin pretty good!
 
1 - 7 of 7 Posts
Top