Modded Mustang Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter #1
i have an off road h pipe on my car and you can hear a light ticking noise which you can hear better from under the car right behind the front driver side wheel. i think its just the h pipe not tightened all the way because my 94 made the same sound when i put the h pipe on it but i wanted to get some better opinions, sorry the video doesnt exactly bring out the sound because i just got done driving and the fan was on but at the end of the video you can hear it. the car only has 42k but i know that doesnt mean it cant be a valve tick or something. ill try to get a better video later. you can here the noise a lot better when in a drive through
 

·
Registered
Joined
·
3,430 Posts
I would treat it as a exhaust leak unless you know for certin that there is no leak. Aftermarket pipes rarely fit up "perfect" and will leak a tad unless given some TLC,
 

·
Registered
Joined
·
3,430 Posts
yeah I know a few guys who have leaks as well. They have even gone as far as using some kind of exhaust RTV sealant. You could look into that if you cant "tighten" it any better
 

·
9k All Day.
Joined
·
3,449 Posts
we RTV'd mine up, even though it fit almost perfect...just in case. :D
 

·
Registered
Joined
·
505 Posts
Discussion Starter #8
i know theres enough people on here with h pipes anybody else get a ticking sound after install?
 

·
Registered
Joined
·
4 Posts
Hey...just ran across this thread after looking online at exhaust leaks and ticking sounds. I know its a little late but it might help. I have an 04 gt with the MAC H-Pipe and Flowmaster 10's. I have a ticking sound coming out of the driver side exhaust pipe. Not sure what it is...could bee the H-Pipe not buttoned up all the way. just changed the plugs 2 weeks ago (56K on the odo) and thats when i actually started paying attention to it....plugs are gapped correctly and no MIL light on for any of the coil packs so i don't think its a plug...i ahev dogged the hell out of the car and no probs but the tick does bother me since it seems to stutter a bit sometimes at idle
 

·
Not that new...
Joined
·
945 Posts
Could be a spark plug getting ready to...



Ahhhhhh, forget it.
 

·
Registered
Joined
·
3,186 Posts
id go and re torque the plugs just for peace of mind. 13 ft/lbs. or 156 in/lbs
 
1 - 12 of 12 Posts
Top