Modded Mustang Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter · #1 ·
sometime ago i posted that i installed my fuel system and supercharger, and that i was getting some backfire noises. well, im not sure, but i think its getting worse. it only happens while in idle, and it sounds like its coming from the mid-pipe or further back towards the mufflers. sometimes its just a puff of high pressure air (causing it to blow smoke rings that is pretty cool!!), but sometimes it can be a shotgun blast. anyone else run into this issue? what do you think it could be? i checked all connections in the exhuast, and as far as ican tell, it's not gulping any excess air along the exhuast track. im confused.
 

·
Registered
Joined
·
13,629 Posts
Sounds like for some reason you are getting unburnt gases into your exhaust and it is igniting. For some reason you are not getting complete combustion in one or more of your cylinders. Pull your plugs and check them. Could be running rich, could be an intermittent spark, could be a lot of things.
 

·
Registered
Joined
·
1,254 Posts
at idle i would say don't worry about it. but if it is a shotgun blast i would be!!
go to your dyno shop and have it retuned and check your fuel filter too i finally changed mine and it was terrible.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #5 ·
thanks, only issue is there is no dyno near me. closest one is in stutgart, nearly 6 hours away.
 

·
Registered
Joined
·
3,680 Posts
so at idle it just back fires???? uhh thats not good/normal...

could be spark related first.. coil is shot and is energizing sporadically, broke plug?

vac. leak? can you elaborate? do you smell or taste gas at idle? (or whats your afr at idle)

is the engine making power normally every where else?

when did this start??? video perhaps??
 

·
Registered
Joined
·
812 Posts
It is a good idea to contact the company you got the S/C from and see what they suggest for spark plugs and gapping. you may need to run a higher temp plug.
 

·
Registered
Joined
·
13,629 Posts
It is a good idea to contact the company you got the S/C from and see what they suggest for spark plugs and gapping. you may need to run a higher temp plug.
Isn't it a Colder heat range plug?
 

·
Registered
Joined
·
3,680 Posts
yes, at boost levels safe for a stock bottom end he wont need much more than one degree colder plug.

there is something else going on besides just a heat range difference to affect it like this just at idle... can you isolate the cylider with a computer or your ear? then try swapping stuff like injectors and coil around? worth a shot and way cheaper than going to the mechanic....
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #10 ·
well, i am running the colder plug. i thought about that maybe its within a certain cylinder, and i have tried isolating the cylinder, but no out of the norm noise is coming from the engine itself, its freaking weird. the noise seems to generate from the mid-pipe back. i chcked my cats, and they seem fine. im freaking stumped. heres a question, could it be the fuel itself. after all, here in germnay, the fuel is actually not as good as back home?
 

·
IBEATU
Joined
·
5,919 Posts
My car has a lot more "popping" in the exhaust after my supercharger. Although I have nothing like a shotgun going off. Your air/fuel will be a lot richer with your supercharger tune, there is no getting around that. More popping will be normal but nothing as extreme as a shotgun. I'm with qwik on this, we need a video
 

·
Registered
Joined
·
2,791 Posts
Sounds like the tune. What kind of supercharger and does it get worse when it is cooler outside?

Sounds like the transiant fuel table in tune may be off. Depending on intake design it could be causing fuel puddling in intake runners and becoming lean. I've been seeing this with Kenne Bell since the weather has gotten colder.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #14 ·
vortech v-3 w/aftercooler, and no, it the same no matter the temp. the thing thats really wierd is that its only in nuetral. when she's in gear and moving, she really pulls and doesnt miss a beat
 

·
Registered
Joined
·
812 Posts
im sorry, cooler, im a moron lol
 

·
Registered
Joined
·
817 Posts
Dude that happens with my kennebell from day one,tuning will help but probably wont get rid of it.That backfiring i had it when i got on it,hto heat range cooler plugs were done changed to brisk or even just being a new set of plugs solved the problem.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top