Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
is a exhaust smell normal for the 5.0 when it doesn't have the cats installed i have a x pipe and full exhaust it doesn't smell like burnt oil or coolant alittle nauseating though my wife told me it smelled when driving behind me epec when i full throttled it
 

·
Registered
Joined
·
368 Posts
make sure you dont have a leak, exhaust fumes rise into the car then


he said that his wife smelt the fumes when she was driving behind him not that he smelt it in the car so i think shes just smelling exhaust w/o cats with tends to be much stronger.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
well it smells a bit better now that i cleaned the maf it was coated with that kn oil had to replace the filter to surprising thing is the filter had holes in it the filter was falling apart in my intake! good thing i caught it before it sucked the intire thing in. can i use maf cleaner to clean the iac(sensor on the intake pipe after maf before throttle body.)
btw the filter wasnt old maybe 4 months never oiled it but i dont drive more than 5 miles to work so thought it wasnt time to clean yet. also the rubber was spilting apart at the base
 

·
Registered
Joined
·
1,002 Posts
he said that his wife smelt the fumes when she was driving behind him not that he smelt it in the car so i think shes just smelling exhaust w/o cats with tends to be much stronger.
yea, didnt see that part..thats right,
 

·
Registered
Joined
·
386 Posts
well it smells a bit better now that i cleaned the maf it was coated with that kn oil had to replace the filter to surprising thing is the filter had holes in it the filter was falling apart in my intake! good thing i caught it before it sucked the intire thing in. can i use maf cleaner to clean the iac(sensor on the intake pipe after maf before throttle body.)
btw the filter wasnt old maybe 4 months never oiled it but i dont drive more than 5 miles to work so thought it wasnt time to clean yet. also the rubber was spilting apart at the base
I've had my K&N in for over 2 years(probably 30k on it) I haven't oiled it and the rubber isn't coming apart at all. Still looks like it did the day I took it out of the box. I do clean it with an air blower every oil change though.
 
1 - 7 of 7 Posts
Top