Modded Mustang Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter · #1 ·
Been a little over a year since I had my 99 GT, and I miss having a car that I enjoy working on, so yesterday I picked up an 03 GT with 135k miles! Honestly I overpaid for it a bit, but I don't care! This time around I'm going to do everything right, now that I have some disposable income.

https://imgur.com/a/3Yiq3Ig

As you can see it has been in an accident. Hopefully Tuesday i'll sell the white car in front of it and then use the money to buy everything it needs.

What's strange is this doesn't like to rev as much as my 99 did. After around 4,500-5,000 rpm this falls on its face. The 99 I had would pull decently all the way to the limiter, but this haates life after 5k. I'm thinking maybe there's something up with the exhaust? Or maybe just the MAF needs cleaning. Not sure. Anyways, expect lots of pics as I it to its former glory! And then some :grin2:
 

·
Registered
Joined
·
22,813 Posts
I don't think it is the exhaust holding it back from revving, I know my 03 GT would go to the limiter no problem.

I remember piecing mine together after I had a front end accident. Looks like you aren't missing much luckily. Looks like just a hood, header panel, headlights, front bumper and bumper cover.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #3 ·
I don't think it is the exhaust holding it back from revving, I know my 03 GT would go to the limiter no problem.

I remember piecing mine together after I had a front end accident. Looks like you aren't missing much luckily. Looks like just a hood, header panel, headlights, front bumper and bumper cover.
Yeah there's also some weird stuff going on with the ac. I see some lines are disconnected and such. Also some wiring needs to be cleaned up and some vacuum lines re-routed. I hope to get an AIT Racing carbon fiber cowl inducted hood along with a cobra bumper. I think it'll look great.
 

·
Registered
Joined
·
4,557 Posts
Most likely its spark or fuel related. A failing cop or fuel pump will cause these issues.

Nice stang man, I couldnt imagine not having a mustang.
 

·
Registered
Joined
·
1,442 Posts
Damn, it's a shame were on opposite ends of the country. I have an oem front bumper, hood, and side skirts in electric green laying around. Would have been a cheap fix.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #7 ·
Damn, it's a shame were on opposite ends of the country. I have an oem front bumper, hood, and side skirts in electric green laying around. Would have been a cheap fix.
Damn. There is a Mustang sitting in a safeway parking lot on blocks of wood thats been there for several months now that im thinking about uhhh... Borrowing some parts off of. Its already missing the passanger seat, tail lights, a window, the stereo, etc..
 

·
Tuning Junkie
Joined
·
151 Posts
Check and see if it has an autozone cheap replacement intake manifold. Could be holding you back in the upper rpms possibly.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #10 ·
Borrowed those parts off that mustang that's been sitting for months: https://imgur.com/a/QaHKowR

Noticed the heater core has been bypassed, aaaand im guessing that is not going to be easy to replace.. Anyways, has anyone had any experience with AIT? looking into getting one of their carbon fiber cowl hoods and was wondering how the fitment was.
 

·
US Air Force (retired)
Joined
·
13,542 Posts
AIT? As in Air Inlet Temperature? On the 99-00 the AIT sensor is separate from the MAF. It is a small sensor located on the Cold Air Intake.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #13 ·
I did notice that where the CAI connects to the throttle body is loose. No hose clamp on one side and you can easily slip it out by hand. Ill fix it when i get home from work but could this be the issue at higher rpm? Im sure air is coming in without passing the MAF and whatever other sensors are before the throttle body.
 

·
Registered
Joined
·
449 Posts
You may want to replace your fuel filter, at worst it'll be preventative maintenance. Who knows, that could be all that's wrong.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #15 ·
So, been awhile but I have some things to add to the list haha. So far I've gotten both the passenger and driver side airbags, a heater core, some interior and dash lights, clutch and flywheel, fuel pump and fuel filter. I discovered while underneath it the pinion seal on the diff is leaking, so I need to order that now.

Is there some sort of sensor in the front of the car for the airbags that would be ruined or something? Also I hope changing that seal and heater core isnt too difficult haha..
 

·
Registered
Joined
·
4,557 Posts
There is at least 1 airbag sensor behind the front bumper. Also the airbag module is underneath the radio behind the shifter bezel. They cannot be reused when the airbags deploy.
 

·
King Trashmouth
Joined
·
21,891 Posts
Heater core is a big pain in the ass. Might wait and do the airbag stuff at the same time since the whole dash removal thing will let you more easily access the airbag module behind the center console. As for the impact sensors I have no idea where they are. One of my next items is going to be solving the cause of my airbag light. Is it the sensors? Is it the module? Is it due to me screwing something up when replacing the heater core? Who knows!
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #19 ·
There is at least 1 airbag sensor behind the front bumper. Also the airbag module is underneath the radio behind the shifter bezel. They cannot be reused when the airbags deploy.
Is this what you're talking about?

https://www.ebay.com/itm/AIR-BAG-CO...:NTgAAOSwh9pa33my:sc:USPSPriority!95327!US!-1

Heater core is a big pain in the ass. Might wait and do the airbag stuff at the same time since the whole dash removal thing will let you more easily access the airbag module behind the center console. As for the impact sensors I have no idea where they are. One of my next items is going to be solving the cause of my airbag light. Is it the sensors? Is it the module? Is it due to me screwing something up when replacing the heater core? Who knows!
Dang it I was hoping it wouldn't be to hard. And I recommend removing the light on your dash. Out of sight out of mind haha.

Also who the **** does this ****? There's a little cover on the transmission where the clutch cable connects that was removed and never put back on. Just big hole in the side of it and you can see the clutch inside.. Lots of little stuff that bugs me, like zip ties without the ends cut off, wires poorly routed, there's a 12 in sub in the back and the box it's in doesn't even fit in the trunk all the way, and the wires from it to the amp are literally just electrical taped together.. Not even good stuff just some shitty jap wrap. And the amp is screwed to the back seat and they made it so you cant fold it down..
 

·
Registered
Joined
·
4,557 Posts
Yea thats it.

I know what you mean op, Im in the middle of un-****ing an 87 Grand Marquis lol. Its been a pia but a fun project. Its almost like building a car at the factory because of all the crap Ive had to do haha!
 
1 - 20 of 32 Posts
Top