Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Commoner
Joined
·
352 Posts
Discussion Starter #1
I just finished a stock rebuild and drove it about 200 miles today. I still have my cats and when I had the midpipe off I torched the O2 sensors a little to get off the carbon but I must be running really rich because my whole bumper has black pollutant on it.. Do fresh rebuilds tend to run rich for little or should this be a concern?
 

·
Registered
Joined
·
808 Posts
If its that rich you should be throwing codes and a CEL. Check that and post findings. do you have a programer or code reader? If not I would atleast get a code reader so you can read and reset codes. Most auto parts stores will read them for you free of charge.
Could be any number of things from a vac leak, exhaust leak before the O2s or bad O2s. What you stated about what you did to your O2s could have ruined them. There are debates on brand replacements , but I would go with FORD o2s.
Good luck.
 

·
Commoner
Joined
·
352 Posts
Discussion Starter #3
If its that rich you should be throwing codes and a CEL. Check that and post findings. do you have a programer or code reader? If not I would atleast get a code reader so you can read and reset codes. Most auto parts stores will read them for you free of charge.
Could be any number of things from a vac leak, exhaust leak before the O2s or bad O2s.
Good luck.
So an OBDII reader should throw a code? And I need to get smogged real soon and Im concerned I may not pass. And btw before the engine rebuild once the engine was warm I would get extremely bad hesitation under 2k. I actually felt it today after the rebuild once the engine was warmed for about 15 mines but went away soon after so im thoroughly confused
 
1 - 3 of 3 Posts
Top