Modded Mustang Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
Well I only got a chance to run twice because I broke my SC tensionor plate. But on that run i ran a 11.83 at 120mph. at the end of the track my tensionor pulley came flying out the bottom of the car. Im hope to get in the mid 11s next time out. I dont know when my belt slipped off on the 11.83 run. Im sure the car has mid 11s in it. this is on drag radials also.
 

·
Registered
Joined
·
8,852 Posts
11.4s or very low 11.5s with that mph
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #4 ·
I think it has low 11s in it. i think my blower belt has been slipping so when i put this new heavy dty tensionor on hopefully it wont slip.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #6 ·
It is a 306 that has windsor jr. heads, cam, cobra intake and a vortech T-trim on it. the supercharger is pulling 7lbs of boost but i think thats because my belt is slipping.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #8 ·
yea i had a paxton sn89 serious the old school one that quit working on me so i bought just the t-trim unit off a guy on ebay for 1200 bucks brand new. Yea it seems like the t-trim makes alot more power on the big end then the strim or paxton novi serious because ive raced a few guys with those and they hang with me until third and then i just pull really hard on them.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #10 ·
Thanks
 
1 - 10 of 10 Posts
Top