Modded Mustang Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
hey guys, so 2 days ago I installed a new airtex fuel pump in my 1998 gt. when i put the fuel pump assembly in its holder i stuck my hand in to make sure the float moved up and down. so when i turned on the car intially after install it read empty which was correct because the tank was dry, then i put in about 3 gallons of gas and it read las then quarter tank full. then i drove to the gas station and filled up, thats were the problem started, the gauge read 3/4 of a tank full when i fully topped off the tank and has been stuck there ever since. I'm going to drop the tank again this weekend, just annoys me to do somethingg twice. so you guys have any suggestions as to what it could be? I think i'm just going to switch this new pump into my old assembly because i know my old send unit works i just switched it cuz i didnt want it going out.
thanks for the suggextions in advance.
 

·
Registered
Joined
·
11,354 Posts
Did you reconnect the vacum line when re installing the tank? Theres a vacum line hose thats connect near the back of the tank (when your facing the rear of the car). Make sure that is re connected.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
yea the vaccum line was connected, theres only one way the pump can ift in the carriage right? after i stuck the pump assembly in the carriage i made sure it could not pull out and i stuck my hand in to make sure the float went up and down without being stuck. i think i got a defective unit :(
 

·
Procrastinator
Joined
·
4,558 Posts
is it possible that you would have bent the float? When I had my gas tank apart I had considered bending it some so that it would read empty early.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
anymore ideas on this, i just pulled out the fuel pump again and reinstalled it and still does this, it never did this till i replaced the fuel pump
 

·
Registered
Joined
·
470 Posts
weird, could just be the guage cuz ive never had any work done to any of my fuel parts but my needle goes 1/4th tank past full when i fill up and then im out of gas at an 1/8th tank but pissing my pants if i drop under a 1/4 cuz the needle is tricky iv ran outta gas a couple times lol dunno if that helps but 2 cents for ya.
 

·
Rollin' 18/ pushin' 2
Joined
·
8,333 Posts
weird, could just be the guage cuz ive never had any work done to any of my fuel parts but my needle goes 1/4th tank past full when i fill up and then im out of gas at an 1/8th tank but pissing my pants if i drop under a 1/4 cuz the needle is tricky iv ran outta gas a couple times lol dunno if that helps but 2 cents for ya.

Sounds like someone pulled your needles off and didn't get them back on right. Do you have aftermarket guages?

either way you can pull the cluster face off and use a fork to remove the needle and put it back in the right place.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #10
no its totally stock, before my fuel pump when out the gauge worked totally fine, i changed the whole fuel pump and module and the needle would move to 3/4 tank full when the tank was actually full, and when it was empty it would read 1/4 full still, so then i using the stock sending unit and just installed that in, now the gauge just reads full and it been that way for 60 miles now. hardly any movement, it seems like the fuel pump assembly can go only one way in the cradle, and i made sure it is snapped in, i even stuck my hand in and made sure the float moves up and down. the float is pointed at the driver side rear wheel. i made sure the vaccum lines are hooked up too. im so lost.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #11
i have a feeling im not installing the fuel pump correctly into the basket, can someone tell me how i get it into the basket the right way? people say its kind of trickey. ive pulled the damn fuel pump assembly 4 times now...
 
1 - 13 of 13 Posts
Top