Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter #1
ive been havin this problem with the car (01 mustang gt) for a while (it runs like crap)

to be more specific its got no kind of power anymore, i checked the codes and one popped up b1220 (fuel tank pressure sensor, circuit open) something to that effect
i check the fuel pressure and at idle the pressure is 25psi give or take a pound.

i removed the fuel vacuum line and it climbs back up to 38psi...

can any one know whats going on with the car or can atleast point me in the right direction? any help would be greatly appreciated
 

·
US Air Force (retired)
Joined
·
13,542 Posts
How are you checking the fuel pressure? Reading it from a data log or using an aftermarket gauge to test the pressure on the fuel rails? If you are using a data log then it should read approximately 40 psi all the time. The computer is calculating the pressure differential across the injectors. If you are using an aftermarket gauge to measure the pressure at the fuel rails then it should read approximately 30 psi at idle and 40 psi with no vacuum. When cruising it should be mid-30s and at WOT approximately 40 psi (assuming you do not have a supercharger). A rough fuel rail pressure is 40 - (vacuum/2). My car has 18 in.hg. of vacuum at idle. 40 - (18/2) = 31 psi. My after market fuel pressure gauge reads 30 psi. When datalogged though, the datalog reads a constant 40 psi. They measure different things.
 

·
Registered
Joined
·
291 Posts
Discussion Starter #3
ive been using a regular gauge reading from the schroeder valve on the fuel rail
and like before its roughly 25 psi at idle and then with the vacuum line removed it runs at about 38

ive got no way of running a data log :/
so im just goin of what i can lol
 
1 - 3 of 3 Posts
Top