Modded Mustang Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #1 ·
I need to change my fuel filter and i changed my plugs like 7,000 miles ago. They should still be fine. And i have had this miss and i cant figure out what the hell it is. After driving home from school i pull in the driveway and my idle drops to like 3-400 rpms and almost stalls. Im gonna change the plugs and fuel filter soon. and i guess ill try to check the cops after that.. Im just getting so tired of having to fix this car.. Any input on what it could be would be great..
 

·
Registered
Joined
·
374 Posts
mabe the plug wires?
 
  • Like
Reactions: gray8188

·
Banned
Joined
·
11,614 Posts
my cars slight miss was a bad cop, but it was only under load
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #4 ·
im thinkin its the cops..
 

·
Banned
Joined
·
11,614 Posts
too bad karcraft went out of buisness, i got all 8 for i think 65 bucks shipped
 

·
Banned
Joined
·
7,007 Posts
Just spitballing but could it maybe be a fuel pressure regulator? Like 93hatch said too COPs are likely the culprit. Fuel pump and/or filter...
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #7 ·
Just spitballing but could it maybe be a fuel pressure regulator? Like 93hatch said too COPs are likely the culprit. Fuel pump and/or filter...
Yea im gonna switch the plugs and change the fuel filter and see were that gets me. Then ill start checkin other things if need be.. Thanks for the input guys. Repped..
 

·
Banned
Joined
·
7,964 Posts
What you said sounds good. Start with the plugs and fuel filter and while youre doing the plugs check the coils with a dvom, shouldnt take but 10 seconds a piece if that since they will already be removed.
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #9 ·
What you said sounds good. Start with the plugs and fuel filter and while youre doing the plugs check the coils with a dvom, shouldnt take but 10 seconds a piece if that since they will already be removed.
I need to buy one weres a good place to get one??
 

·
Banned
Joined
·
7,964 Posts
If its something you dont have a use for on a usual basis etc id just run by sears or home depot/lowes and pick one up. Theyre not too expensive.
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #11 ·
If its something you dont have a use for on a usual basis etc id just run by sears or home depot/lowes and pick one up. Theyre not too expensive.
Ight thanks man ill do that.. Repped..
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #12 ·
What you said sounds good. Start with the plugs and fuel filter and while youre doing the plugs check the coils with a dvom, shouldnt take but 10 seconds a piece if that since they will already be removed.
Im getting the ngk tr6's cause im getting tuned for the spray soon 100-125 shot. What should i gap them at..
 

·
Registered
Joined
·
2,363 Posts
you've got a bad coil....ford sho's have the same issues when the coils start acting up...
finding it is another problem...they normally act up when they are hot....
good luck!!
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #14 ·
you've got a bad coil....ford sho's have the same issues when the coils start acting up...
finding it is another problem...they normally act up when they are hot....
good luck!!
Yep i should be able to find it with a volt tester tho. The only thing that is a pita is that some of the bolts holding down my cops are stripped.. So i might if i can come up with the money buy a new intake manifold cause its a pain to pull the cops..
 

·
Registered
Joined
·
2,363 Posts
from what i have noticed on the sh0's they read fine when under normal temps, but when they get hot....that's when they act up..
good luck with it and keep us posted...
actually my sho now is doing the same thing, but it has a slight miss at idle, and this is only present after the car warms up, otherwise it runs fine..
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #16 ·
from what i have noticed on the sh0's they read fine when under normal temps, but when they get hot....that's when they act up..
good luck with it and keep us posted...
actually my sho now is doing the same thing, but it has a slight miss at idle, and this is only present after the car warms up, otherwise it runs fine..
Yea mine has a slight miss pretty much all the time.. And ill keep everyone updated it wont be until this weekend till i get around to it tho. Ive got class all week.:(
 

·
Registered
Joined
·
2,363 Posts
sometimes it can be a bitch to find the bad coil.....if your do and got the miles and cash upgrade to some msd's :)
 

·
Banned
Joined
·
491 Posts
i have 8 coil packs aswell.
 

·
Registered
Joined
·
3,522 Posts
Discussion Starter · #20 ·
1 - 20 of 27 Posts
Top