Modded Mustang Forums banner

1 - 4 of 4 Posts

·
KILLER
Joined
·
1,722 Posts
Discussion Starter #1
Anyone with a 2010 gotten these to work? i got them today, they dont fit worth a crap.. Called the place i got them and they said im not the first caller today who has had the issue of them not fitting..
 

·
Registered
Joined
·
168 Posts
Just got mine last week for head lights and fog lights.

The fog light covers were a no brainer and worked out perfectly. The headlights were a whole different story:( Out of the 2 black plastic clips at the bottom of each cover one was broken off before I even pulled it out of the package and 2 others broken trying to get the covers to fit correctly. I ended up ripping the remaining clip off and putting stick on velcro in each bottom corner of both covers. I bought the 1" velcro squares from Advance Auto Parts. That seems to have done the trick as I haven't had any problems since installing them this way. The other problem I had was the part of the cover that hooks over the top of the headlight on the drivers side. It wouldn't let the cover sit far enough towards the center of the car to cover the entire light. I had to use a belt sander to sand the side of the hook down enough to let it sit where it needed.

Yes, the original fitment was far from great but with a little coaxing I got them to work and they look absolutely awesome! I get comments on their looks all the time!





.
 

·
KILLER
Joined
·
1,722 Posts
Discussion Starter #3
well, i smashed mine on the garage floor.. so no hope for me to fix it. im thinking im just gunna get them tinted.
 
1 - 4 of 4 Posts
Top