Modded Mustang Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
3,528 Posts
Help. Car is running like sh!^.

Hey so i did a cam install. started it up today. it starts. it kept dieing and almost dieing, im assuming that part is just because i dont have a tune, but i go to drive it and its so ****ing jerky like i touch the gas and it ****in jerks like im just learning to drive standard or something, anyone know what could be the problem? and if i can fix it just with my SF3 tuner?
 

·
Registered
Joined
·
16,245 Posts
if your dead sure the timing is right then im going to guess that you DEFINITELY need a tune.
 

·
Registered
Joined
·
3,528 Posts
Discussion Starter · #3 ·
it idles fine, its when i start actually driving it.. i dunno what it is. im wondering if theres any like air fuel ratios i can change or what that would make it a bit more managable so i can drive it to a shop
 

·
Registered
Joined
·
16,245 Posts
tow it... you prolly just need a tune bad. Think about it! that car is totally ****ed from what that computer is trying to do.
 

·
Premium Member
Joined
·
9,751 Posts
tow it... you prolly just need a tune bad. Think about it! that car is totally ****ed from what that computer is trying to do.
+1^
 

·
Registered
Joined
·
1,923 Posts
yea u need a tune because right now your car still thinks it has the stock cams in it
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
<---Votes Tune.
 

·
Registered
Joined
·
5,472 Posts
I could see a tune keeping it from running great or idle a little bad, but it shouldn't cause it to be as bad as you describe. I would check for vacuum leaks unplugged connectors like maf, crank position, and cam position sensors.

I changed my cams and drove it 220 miles to my tuners it ran pretty good even before my tune.
 

·
Registered
Joined
·
3,528 Posts
Discussion Starter · #9 ·
thanks jivepepper. it was the MAF plug. i also didnt notice that my jlt intake didnt use the stupid plug thats connected to that maf plug either. not sure what it is,
 

·
Registered
Joined
·
16,245 Posts
i was thinking the same thing jive said. Yellow said his was driving pretty descent after his cam install. Glad you found it.
 

·
Registered
Joined
·
3,528 Posts
Discussion Starter · #11 ·
Here is a video of it. sorry its pretty shitty, its like 2 am and i was tired as ****, but you get the idea. **** it sounds so good lol.

[ame=http://s129.photobucket.com/albums/p216/energiesource/?action=view&current=1252828815.flv]
[/ame]
 

·
Premium Member
Joined
·
9,751 Posts
thanks jivepepper. it was the MAF plug. i also didnt notice that my jlt intake didnt use the stupid plug thats connected to that maf plug either. not sure what it is,
thats the connector for your air inlet temp sensor on a 2000, you need to transfer the sensor into your new cold air kit or it'll never run right.
 

·
Registered
Joined
·
1,203 Posts
hey man what cam did you decide to go with?
 

·
Registered
Joined
·
5,472 Posts
thanks jivepepper. it was the MAF plug. i also didnt notice that my jlt intake didnt use the stupid plug thats connected to that maf plug either. not sure what it is,
No problem

thats the connector for your air inlet temp sensor on a 2000, you need to transfer the sensor into your new cold air kit or it'll never run right.

yeah that's what i think he means too.
 

·
Registered
Joined
·
3,528 Posts
Discussion Starter · #15 ·

·
Registered
Joined
·
828 Posts
what are the stats for the cam?
 

·
Registered
Joined
·
5,175 Posts
did you end up using the same springs or did you upgrade also how much did the cams cost you
 

·
Registered
Joined
·
432 Posts
i know its the tune lol. when i put my stroker in before i put my break in tune in it wouldnt idle for **** and jerkes around. even with the break in tune it still jerks like a rabbit haha
 

·
Penetration before detonation
Joined
·
2,189 Posts
Dammit, Jive, you beat me to it! I came across this post and read it, and then said to myself "MAF..." and then I scrolled down and saw you stole my thunder! Damn you! :mad:

Just playin Jive. :hug
 

·
Registered
Joined
·
1,544 Posts
did you end up using the same springs or did you upgrade also how much did the cams cost you
I have the same cams. I got them on sale for 500$ and the springs were another 200. Kelly(from modularspeed) says not to run stock springs with em. They aren't a crazy cam but they sound great and make good power.
 
1 - 20 of 22 Posts
Top