Modded Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
399 Posts
Discussion Starter #1
So car was apart this winter for fuel system and few other updates. I went return style fuel system with a1000 pump, 80 lb injectors, and changed from pmas mass air to sct ba3000. I got a start up tune from Tim Barth car ran pretty decent but I always had a p1121 tps inconsistent with mass air code. The car still ran and idled, the other day I took the tube the mass air is on off to polish it put it all back together and now the car doesn't want to idle. It sounds like it has HUGE cams, smokes, and smells like fuel, if I unplug it the car idles fine. Any ideas? If its plugged in I can hold the throttle at a rpm but runs rough like its getting way too much fuel. Any and all help is greatly appreciated.



I thought maybe I didn't get the mass air back in the same position and I need to spin it. Here is a pic of the setup.











 

·
Registered
Joined
·
11,469 Posts
man you got that bov really close to the maf it could be messing with your maf counts. also its probably the position of the maf change. it does not take much to throw off a tune.
 

·
Registered
Joined
·
1,212 Posts
Stal is right. We are talking millimeters of difference changes things. That BOV is dangerously close I agree.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #4
I thought it was close myself but it was fine last year after a dyno tune. I'll rotate the mass air back to the location it was in and see if that fixes or helps. That is the only thing I can think of. A bad tps wouldn't cause this would it?
 

·
Registered
Joined
·
11,469 Posts
the way your bov is placed its going to need a retune cause any slight re-angle will throw off the tune. also the code your getting is not for a bad tps, its a common code when people have blow threw issues.
 

·
Registered
Joined
·
11,469 Posts
also you said you have a can tune for your ba 3000 maf right? your tuner is going to have a hard time getting it right with the senser in a 3" pipe. the small diameter pipe really speeds the air up and you will run pig rich till he retunes it. you tps senser is probably fine, just needs a tune
 

·
Registered
Joined
·
11,469 Posts
also why are you not using your pmas anymore? it was probably calibrated to run in the 3" housing. the ba 3000 is not really a good maf for blow threw in a 3" housing, you cut the range down a ton, and the resolution kind of goes to crap.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #10
Was your AFR good the first dyno?
It hasnt been on a dyno since last year.

also why are you not using your pmas anymore? it was probably calibrated to run in the 3" housing. the ba 3000 is not really a good maf for blow threw in a 3" housing, you cut the range down a ton, and the resolution kind of goes to crap.
The pmas was junk kept saying mass air flow sensor intermittent, sent it back and they did nothing. I replaced it now its fine. Fastlane told me to run it this way.
 
1 - 11 of 11 Posts
Top