Modded Mustang Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter · #1 ·
ok guys i bought a daily driver, well actually i had one but i upgraded to a 1991 isuzu impulse rs, it is an extreamly rare car 1 of only 800 imported into north america. Turbo charged awd.

ok u turbo guys i need some help. when in boost it studders, in vacuum it runs like a charm. today i replaced the plugs and ignition coils and it ran extreamly good for about 5 min. then on the way back home it started studering agian. i just lowered the spark plug gap to .032. any other tips, by the way the normal boost is 7psi making 160hp with a 4 cyl i need some help. this is my DD and the more i spend on it the more i cant spend on my baby stang. which sux

thanks guys
 

·
Registered
Joined
·
3,680 Posts
stock plugs? check the wires, coils... injectors.. common sense stuff first.
 

·
Premium Member
Joined
·
4,253 Posts
ok guys i bought a daily driver, well actually i had one but i upgraded to a 1991 isuzu impulse rs, it is an extreamly rare car 1 of only 800 imported into north america. Turbo charged awd.

ok u turbo guys i need some help. when in boost it studders, in vacuum it runs like a charm. today i replaced the plugs and ignition coils and it ran extreamly good for about 5 min. then on the way back home it started studering agian. i just lowered the spark plug gap to .032. any other tips, by the way the normal boost is 7psi making 160hp with a 4 cyl i need some help. this is my DD and the more i spend on it the more i cant spend on my baby stang. which sux

thanks guys
Check the vacuum line to the waste-gate - my Turbo Omni GLH did that back in the day when that line came loose.
 
1 - 5 of 5 Posts
Top