Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
ok, im a newb at brakes in general, so when it comes to drum brakes im completely dumbfounded....i have a 89 5.0 with drum brakes and recently my brakes decided to stop working, I used to only have to pump the pedal twice to get a solid brake, now it seems I have to pump it 4-6 times just to get it to slow down, does this mean there is a leak somewhere in my brake line?? or something else?? please help, thanks.
 

·
Registered
Joined
·
1,182 Posts
check your fluid level first,if this is out of the blue as you said it sounds like maybe a bad master cylinder.
 

·
Registered
Joined
·
3,245 Posts
could be, or could be you have a line that is leaking somewhere, Just out of curiosity you are just now worrying about this, when you said before you only had to pump the brakes a couple of times to get them to work? I think you better park that car until you get the brakes fixed, its not expensive but if you screw something up or wait to long it can be....especially if it costs you a wreck, if you have to stop suddenly there is not time to pump your brakes
 

·
Registered
Joined
·
80 Posts
Discussion Starter #4
thanks fellas i will check both of these, and yes i am aware of the potential risk for accident...have almost gotten into a wreck just yesterday actually, this is my only mode of transport as of right now so I have been driving extremely careful believe me, the old people in the 1990 buicks and cadillacs hate being behind me lol
 
1 - 4 of 4 Posts
Top