Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
I just got a 2002 windstar limited last weekend and sunday got an error code for the emissions, got the code read and replaced the egr valve pressure sensor, after doing that the van started bucking under excelleration, then tonight when I got off work it did it while in park??? What gives and can anybody help me?:eek:
 

·
Registered
Joined
·
101 Posts
That could be something as simple as fouled spark plugs, bad wires, etc... Another potential cause may be a bad transmission sensor as that was a problem I had with a contour last summer. I'd start with all the simple and usual culprits for these problems before investing too much time and money into something that isn't broken. The error codes generated by the computer only can tell what sensor(s) is giving readings outside of normal operating parameters, not the root of the problem, so good old fashioned trouble shooting is still important.
 

·
Banned
Joined
·
15,799 Posts
I just got a 2002 windstar limited last weekend and sunday got an error code for the emissions, got the code read and replaced the egr valve pressure sensor, after doing that the van started bucking under excelleration, then tonight when I got off work it did it while in park??? What gives and can anybody help me?:eek:
check the sensor and the vacuum line to the EGR
also check the PCV valve
mymoms van(2000 windstar) had some what the same symptoms but no engine light and i did the plugs, air filter check, fuel filter and still same ****. new pcv valve and was fine..
idk why didnt seem right still doesnt seem right how it was just the pcv valve:confused:
 

·
Registered
Joined
·
2,419 Posts
was it a p0401 ? If it was you should have never touched the EGR system.
 
1 - 4 of 4 Posts
Top