Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Recently I discovered that I could not lock or unlock the car doors from the control panel on either door, but I could still lock and unlock with Keyfob. I guessed / assumed it was probably a blown fuse and resolved to fix at some point. I then began to notice that my battery seemed to die quite frequently after only sitting for a week (the car is a garage queen and only gets driven usually on weekends). So I took it to the local autozone and had the Alternator and battery checked. They told me the battery was dead, so I replaced and figured my problems were solved. I then started to notice other strange issues like, I no longer have dash lights, then when driving home from the beach last weekend I discovered my head lights were not working and when they finally did they were dim + no fog lights.. It also started running really rough, no power, loud noise in the cabin, etc. It felt like it was trying to die, but it never did and I was able to limp it home. I'm no mechanic and I don't pretend to be, I do wrench on my cars, YouTube is my friend :smile2: . To me this sounds like the Alternator, which has been replaced once probably 11 years ago now. However I have no indicator light on the dash (little battery), and as stated before Autozone said it was not bad. Could it be die'ing and only acting up part of the time? The only electrical work I've done on the car this year was to install the Raxiom Sequential tail light kit with turn signal flasher module, not sure if I was starting to have problems with the dash lights and door locks before or after this mod.
 

·
Registered
Joined
·
105 Posts
If the battery is good and alternator and it keeps on draining you have a parasitic draw. You can verify with an amp meter around the battery cables.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
Mrvince,
Thanks for the response.
Battery seems ok now that I've replaced it. My troubleshooting is more with the fact that I no longer have dash lights, head lights, fog lights, or door locks, and that the car keeps loosing power and feels like its going to die. I haven't started checking fuses yet but find it hard to believe that I would have multiple blown fuses unless there was some kind of power surge or short in the car. I've looked for burn marks, or other visible indicators of a short. I'm wondering if even though I don't have a visual indicator on the dash of a bad alternator, and even though autozone said it was ok, could it be the cause of my issues or should I be looking for something else. I don't know of much else that would effect various electrical systems and engine performance.
 

·
King Trashmouth
Joined
·
21,891 Posts
After all that I'm starting to think bad ground.

First I would do the basic checks.
Check for blown fuses, especially to the interior box, and within the interior box. Note that it's a good idea to test continuity between the posts on the fuses since visual checks aren't always accurate.
Is battery voltage at roughly 12V with key off?
Is the alternator output while running >12.5V?
Test for current draw with car off (amp draw should be near zero).
Test for resistance to ground. Resistance between the negative battery post and locations like the engine block and chassis should be near zero. You can clean the terminals and any attachment points to help, or even test if an extra ground strap from the post to the block or chassis would help.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Well further troubleshooting revealed that either the Raxiom sequential taillight kit was to blame or was yet another victim of my electrical issues. I took out the rear tail lights to look at the wiring and this is what I found on the drivers side.

Since the inside wiring connector was also burned down to the wiring harness, I guess I now have to cut back the tape and trace that out to see how far back the damage goes. Then I'm guessing cut out the connector and replace with a new one. This sucks. Needless to say I'll be reinstalling the factory turn signal relay and taillight wiring harnesses. Hopefully the damage is isolated to just what I can see.
 

Attachments

1 - 5 of 5 Posts
Top